summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlaviu Tamas2016-04-07 14:35:00 -0400
committerFlaviu Tamas2016-04-07 14:35:50 -0400
commitcdac67477f65913af9c948f4c4ea1713ad39951b (patch)
tree424c1cbe9b21438f13887d9c0bb5ffba6138936d
downloadaur-shellpic.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD19
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e773d4ef87ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = shellpic
+ pkgdesc = Shellpic uses escape codes to display images in a terminal, IRC or NUTS client.
+ pkgver = 1.6.2
+ pkgrel = 1
+ url = https://github.com/larsjsol/shellpic
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-pillow
+ source = https://github.com/larsjsol/shellpic/archive/v1.6.2.tar.gz
+ sha256sums = 0cc9c595d5f2c2c8b6157d4b743695c83b7348c4455c42a8ff8062fb2f2f77cf
+
+pkgname = shellpic
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4e8c5855648d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+*
+!.gitignore
+
+!PKGBUILD
+!.SRCINFO
+!*.install
+!ChangeLog
+
+!*.diff
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..deddd6409296
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Flaviu Tamas <tamasflaviu@gmail.com>
+
+pkgname=shellpic
+pkgver=1.6.2
+pkgrel=1
+pkgdesc="Shellpic uses escape codes to display images in a terminal, IRC or NUTS client."
+arch=("any")
+url="https://github.com/larsjsol/shellpic"
+license=("GPL3")
+depends=("python" "python-pillow")
+source=("https://github.com/larsjsol/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('0cc9c595d5f2c2c8b6157d4b743695c83b7348c4455c42a8ff8062fb2f2f77cf')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: