summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2015-06-13 00:25:53 -0500
committerXavierCLL2015-06-13 00:25:53 -0500
commit0f854f7a5989c2df596f2ed7d54e4b8644533286 (patch)
tree01824a5f72239262755c0a5a56989229d1da153a
downloadaur-shellsql.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c6b22499301
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = shellsql
+ pkgdesc = ShellSQL is a suite of programs designed to enable LINUX/UNIX shell scripts to connect to SQL engines and execute SQL queries and commands in a simple way enabling intergration with the rest of the script, support DB: postgres, mysql, sqlite3 and odbc
+ pkgver = 0.7.7
+ pkgrel = 1
+ url = http://shellsql.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ depends = gcc
+ optdepends = postgresql
+ optdepends = mysql
+ optdepends = sqlite3
+ source = http://sourceforge.net/projects/shellsql/files/shellsql/0.7.7/shellsql-0.7.7.tgz/download
+ md5sums = 5b9e714048aa892d312408f401b5bc62
+
+pkgname = shellsql
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ddcac6054ae1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: (epsilom) Xavier Corredor <xavier.corredor.llano (a) gmail.com>
+
+pkgname=shellsql
+pkgver=0.7.7
+pkgrel=1
+pkgdesc="ShellSQL is a suite of programs designed to enable LINUX/UNIX shell scripts to connect to SQL engines and execute SQL queries and commands in a simple way enabling intergration with the rest of the script, support DB: postgres, mysql, sqlite3 and odbc"
+url="http://shellsql.sourceforge.net"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('glibc' 'gcc')
+optdepends=('postgresql' 'mysql' 'sqlite3')
+source=(http://sourceforge.net/projects/shellsql/files/shellsql/$pkgver/shellsql-$pkgver.tgz/download)
+md5sums=('5b9e714048aa892d312408f401b5bc62')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ sed "s_"BINDIR=/usr/bin"_"BINDIR=$startdir/pkg/usr/bin"_g" < install.sh > install2.sh
+ chmod +x install2.sh
+ mkdir -p $startdir/pkg/usr/bin
+
+ #PATCH: fix conflicting declaration for getline in shsqlinp
+ cd src/
+ sed "s_"getline"_"getLine"_g" < shsqlinp.c > shsqlinp.c2
+ mv shsqlinp.c2 shsqlinp.c
+ cd ..
+
+ ./install2.sh postgres mysql sqlite3 odbc tools || return 1
+}