summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoruidops2021-03-20 10:53:03 +0330
committeruidops2021-03-20 10:53:03 +0330
commitb01eea04619b6cc32cbee3222e3d4576fa456405 (patch)
treeb74d62af58354d2d91a2fe71c571a701bb7bf1bd
downloadaur-b01eea04619b6cc32cbee3222e3d4576fa456405.tar.gz
add pkgbuild for version 7.2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..80dfed467763
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = shellter
+ pkgdesc = Dynamic shellcode injection tool
+ pkgver = 13
+ pkgrel = 1
+ url = https://www.shellterproject.com
+ arch = any
+ license = custom
+ depends = wine
+ source = shellter::git+https://github.com/ParrotSec/shellter
+ sha512sums = SKIP
+
+pkgname = shellter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fea0826ea6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=shellter
+pkgver=13
+pkgrel=1
+
+pkgdesc='Dynamic shellcode injection tool'
+url='https://www.shellterproject.com'
+arch=('any')
+license=('custom')
+depends=('wine')
+
+source=(${pkgname}::git+https://github.com/ParrotSec/shellter)
+sha512sums=('SKIP')
+
+package() {
+ install -D -t "$pkgdir/opt/shellter" "$pkgname/shellter.exe"
+ mkdir -p $pkgdir/usr/share/licences/shellter/
+ mkdir -p $pkgdir/usr/share/docs/shellter
+ mkdir -p $pkgdir/usr/bin
+ cp -r $pkgname/debian $pkgname/shellcode_samples $pkgname/docs $pkgdir/usr/share/docs/shellter
+ cp -r $pkgname/licenses $pkgdir/usr/share/licences/shellter
+ cat > "${pkgdir}/usr/bin/${pkgname}" << EOF
+#!/bin/sh
+wine /opt/shellter/shellter.exe
+EOF
+ chmod 755 "${pkgdir}/usr/bin/${pkgname}"
+}