summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Koloberdin2018-08-13 01:18:04 +0300
committerMichael Koloberdin2018-08-13 01:18:04 +0300
commitf8f21d0acee83384aa0d6cc1e9a112d86065c37e (patch)
tree75d636b7423b7fa486b90c5b4e5a55d69614f2fd
parentd5b8ff554fd4a49b0d2aa5e31f7282fbaad85187 (diff)
downloadaur-f8f21d0acee83384aa0d6cc1e9a112d86065c37e.tar.gz
Update to v2.3.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD41
2 files changed, 25 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad8c864e912c..43065e890410 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Aug 12 22:13:51 UTC 2018
pkgbase = shen-sbcl
pkgdesc = A portable functional programming language (SBCL port)
- pkgver = 19.1.p1.9
+ pkgver = 2.3.0
pkgrel = 1
+ epoch = 1
url = http://www.shenlanguage.org/
- arch = i686
arch = x86_64
license = BSD
makedepends = sbcl
depends = zlib
provides = shen
options = !strip
- source = http://www.shenlanguage.org/Download/Shen-SBCL-Linux.zip
- md5sums = 4c58bd0542044fe93539b176dd7e4e2a
+ source = https://github.com/Shen-Language/shen-cl/archive/v2.3.0.tar.gz
+ sha512sums = 63e8de291c6b0779346a473e2dfc391f39440f88c5b1ff3c747a9573e1203691da7d327399b0de52776e94236d86a4480cdadf430783129e5c461be0df573666
pkgname = shen-sbcl
diff --git a/PKGBUILD b/PKGBUILD
index ede46cba248e..03aa37fed10c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,39 @@
-# Maintainer: Alain Kalker <a.c.kalker@gmail.com>
-_pkgname=Shen
+# Maintainer: Michael Koloberdin <koloberdin@gmail.com>
+# Contributor: Alain Kalker <a.c.kalker@gmail.com>
pkgname=shen-sbcl
-_version=19.1
-_port=1.9
-pkgver=$_version.p$_port
+pkgver=2.3.0
pkgrel=1
+epoch=1
pkgdesc="A portable functional programming language (SBCL port)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.shenlanguage.org/"
license=('BSD')
depends=('zlib')
makedepends=('sbcl')
provides=('shen')
options=(!strip)
-source=(http://www.shenlanguage.org/Download/Shen-SBCL-Linux.zip)
-md5sums=('4c58bd0542044fe93539b176dd7e4e2a')
+source=(https://github.com/Shen-Language/shen-cl/archive/v$pkgver.tar.gz)
+sha512sums=('63e8de291c6b0779346a473e2dfc391f39440f88c5b1ff3c747a9573e1203691da7d327399b0de52776e94236d86a4480cdadf430783129e5c461be0df573666')
build() {
- cd "$_pkgname $_version"
+ cd "$srcdir/shen-cl-$pkgver"
+ make fetch
+ make build-sbcl
+}
- cd Platforms/SBCL
- ln -sf "../../KLambda"/*.kl .
- sbcl --no-userinit --load install.lsp
+check() {
+ cd "$srcdir/shen-cl-$pkgver"
+ make test-sbcl
}
package() {
- cd "$_pkgname $_version"
-
- # binary
- install -Dm755 Platforms/SBCL/Shen.exe "$pkgdir/usr/bin/Shen"
+ cd "$srcdir/shen-cl-$pkgver"
- # documentation
- install -d -m755 "$pkgdir/usr/share/doc/$pkgname"
- cp -a Doc/* "$pkgdir/usr/share/doc/$pkgname/"
+ # binary
+ install -Dm755 "bin/sbcl/shen" "$pkgdir/usr/bin/shen"
- # license
- install -d -m755 "$pkgdir/usr/share/licenses/$pkgname"
- cp BSD license.pdf "$pkgdir/usr/share/licenses/$pkgname/"
+ # license
+ install -Dm644 "LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: