summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTércio Martins2017-02-11 19:51:29 -0200
committerTércio Martins2017-02-11 19:51:29 -0200
commitd9b0820be8a54c19d082e0dbc00fc88d0ce0099c (patch)
tree2407fd58060dc38418de2f114195b790886df97d
downloadaur-d9b0820be8a54c19d082e0dbc00fc88d0ce0099c.tar.gz
First commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ddfec92c1371
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = shenidam-git
+ pkgdesc = Lightweight audio mapping software for AV footage
+ pkgver = 1.0.r9.g08b029a
+ pkgrel = 1
+ url = https://stendardo.org/shenidam
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ makedepends = git
+ depends = boost-libs
+ depends = fftw
+ depends = libsamplerate
+ depends = libsndfile
+ depends = python2-pyqt4
+ provides = shenidam
+ conflicts = shenidam
+ source = git+https://github.com/stendardo/shenidam
+ md5sums = SKIP
+
+pkgname = shenidam-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f83caee7bccc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Tercio Martins < echo dGVjbm90ZXJjaW8ge2F0fSB5YWhvbyB7ZG90fSBjb20ge2RvdH0gYnIK | base64 -d >
+
+pkgname=shenidam-git
+_pkgname=shenidam
+pkgver=1.0.r9.g08b029a
+pkgrel=1
+pkgdesc="Lightweight audio mapping software for AV footage"
+arch=('i686' 'x86_64')
+url="https://stendardo.org/shenidam"
+license=('GPL')
+depends=('boost-libs' 'fftw' 'libsamplerate' 'libsndfile' 'python2-pyqt4')
+makedepends=('boost' 'git')
+provides=('shenidam')
+conflicts=('shenidam')
+source=('git+https://github.com/stendardo/shenidam')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ mkdir build
+ cd build
+ cmake -DPYTHON_EXECUTABLE:FILEPATH=/usr/bin/python2 \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr ..
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}/build"
+ make DESTDIR="$pkgdir/" install
+}