summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpeeweep2019-10-05 09:53:36 +0800
committerpeeweep2019-10-05 09:53:36 +0800
commit104d2ed5d9d35f45a2168986f874733d781b9624 (patch)
tree003c724f00c4e5e3edc3ec696b6a084c300e280b
parente04b57fd78fccb6d13e1859ce204f5562242d87c (diff)
downloadaur-104d2ed5d9d35f45a2168986f874733d781b9624.tar.gz
Update path
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rwxr-xr-xsherlock.sh2
3 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 284750c1717b..215e34177a39 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sherlock-git
pkgdesc = Find usernames across social networks
pkgver = 20191002.d8290d5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sherlock-project/sherlock
arch = any
license = MIT
@@ -15,10 +15,10 @@ pkgbase = sherlock-git
depends = python-requests-futures
depends = python-soupsieve
depends = python-stem
- source = sherlock::git+https://github.com/sherlock-project/sherlock.git
+ source = sherlock-git::git+https://github.com/sherlock-project/sherlock.git
source = sherlock.sh
sha256sums = SKIP
- sha256sums = a50fa6f5b78be38e0cb63fd6069df971d27a3ee31bf699af254d6cc869cb2151
+ sha256sums = 45bb5034d63681f3e0f0d12f868465024a473b12b2751b00e968fcb7a935497c
pkgname = sherlock-git
diff --git a/PKGBUILD b/PKGBUILD
index 0030924d4ce8..9268fdc6eeb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: peeweep <peeweep at 0x0 dot ee>
pkgname=sherlock-git
-_pkgname=sherlock
pkgver=20191002.d8290d5
-pkgrel=1
+pkgrel=2
pkgdesc="Find usernames across social networks"
arch=('any')
url="https://github.com/sherlock-project/sherlock"
@@ -21,21 +20,21 @@ depends=(
)
makedepends=('git')
source=(
- "${_pkgname}::git+${url}.git"
+ "${pkgname}::git+${url}.git"
"sherlock.sh"
)
sha256sums=('SKIP'
- 'a50fa6f5b78be38e0cb63fd6069df971d27a3ee31bf699af254d6cc869cb2151')
+ '45bb5034d63681f3e0f0d12f868465024a473b12b2751b00e968fcb7a935497c')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${pkgname}"
git log -1 --format='%cd.%h' --date=short | tr -d -
}
package() {
- install -Dm755 "${srcdir}/sherlock.sh" "${pkgdir}/usr/bin/sherlock.sh"
- cp -r "${srcdir}/${_pkgname}" "${pkgdir}/usr/share/${_pkgname}"
- install -Dm644 "${srcdir}/${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm755 "${srcdir}/sherlock.sh" "${pkgdir}/usr/bin/sherlock"
+ install -Dm644 "${srcdir}/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/sherlock/LICENSE"
+ cp -r "${srcdir}/${pkgname}" "${pkgdir}/usr/share/"
}
# vim:set ts=2 sw=2 et:
diff --git a/sherlock.sh b/sherlock.sh
index 5d04388aa65e..682eb01e7b51 100755
--- a/sherlock.sh
+++ b/sherlock.sh
@@ -1,2 +1,2 @@
#!/usr/bin/bash
-python ../sherlock/sherlock.py "$@"
+python /usr/share/sherlock/sherlock.py "$@"