summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2021-10-15 11:53:31 +0200
committerCarl Smedstad2021-10-15 12:00:17 +0200
commit19d0b2f59390a343d11a227e1f5e6389cb8ac757 (patch)
tree9e6117837261f52a8624c2857b0fb64b792a3637
parent2e6cf584cb0f6c12164318cd909e30da5f414469 (diff)
downloadaur-19d0b2f59390a343d11a227e1f5e6389cb8ac757.tar.gz
Release version 3.4.0
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD41
2 files changed, 42 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2980aa958223..e756d0e61303 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,27 @@
pkgbase = shfmt-bin
- pkgdesc = Format shell programs (pre-compiled static binary)
- pkgver = 2.6.0
+ pkgdesc = Format shell programs
+ pkgver = 3.4.0
pkgrel = 1
url = https://github.com/mvdan/sh
arch = x86_64
+ arch = i386
+ arch = armv7h
+ arch = aarch64
license = BSD
+ depends = glibc
provides = shfmt
conflicts = shfmt
- source_x86_64 = https://github.com/mvdan/sh/releases/download/v2.6.0/shfmt_v2.6.0_linux_amd64
- source_x86_64 = https://raw.githubusercontent.com/mvdan/sh/v2.6.0/LICENSE
- sha256sums_x86_64 = e582c3417f1b773598c219683a98cc1ce444ca04aef1fa8457c378ad00316b29
- sha256sums_x86_64 = ce63850f77649f00d1394045e2794ffb09a5596beabac51c9548edd958845d7c
+ noextract = shfmt-bin-3.4.0.LICENSE
+ noextract = shfmt-bin-3.4.0.shfmt
+ source = shfmt-bin-3.4.0.LICENSE::https://raw.githubusercontent.com/mvdan/sh/v3.4.0/LICENSE
+ sha256sums = ce63850f77649f00d1394045e2794ffb09a5596beabac51c9548edd958845d7c
+ source_x86_64 = shfmt-bin-3.4.0.shfmt::https://github.com/mvdan/sh/releases/download/v3.4.0/shfmt_v3.4.0_linux_amd64
+ sha256sums_x86_64 = 5cd7a2b57a0592f919ca2e4249bd567ae3426801a28ae94d0b26f8f2c4ce17f9
+ source_i386 = shfmt-bin-3.4.0.shfmt::https://github.com/mvdan/sh/releases/download/v3.4.0/shfmt_v3.4.0_linux_386
+ sha256sums_i386 = 5cd7a2b57a0592f919ca2e4249bd567ae3426801a28ae94d0b26f8f2c4ce17f9
+ source_armv7h = shfmt-bin-3.4.0.shfmt::https://github.com/mvdan/sh/releases/download/v3.4.0/shfmt_v3.4.0_linux_arm
+ sha256sums_armv7h = 5cd7a2b57a0592f919ca2e4249bd567ae3426801a28ae94d0b26f8f2c4ce17f9
+ source_aarch64 = shfmt-bin-3.4.0.shfmt::https://github.com/mvdan/sh/releases/download/v3.4.0/shfmt_v3.4.0_linux_arm64
+ sha256sums_aarch64 = 5cd7a2b57a0592f919ca2e4249bd567ae3426801a28ae94d0b26f8f2c4ce17f9
pkgname = shfmt-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index a61e19abfff9..64fedc016313 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,34 @@
-# Maintainer: Daniel Martí <mvdan@mvdan.cc>
+# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
+# Contributor: Daniel Martí <mvdan@mvdan.cc>
pkgname=shfmt-bin
-_pkg=sh
-_name=shfmt
-pkgver=2.6.0
+_pkgname=shfmt
+pkgver=3.4.0
pkgrel=1
-pkgdesc="Format shell programs (pre-compiled static binary)"
-url="https://github.com/mvdan/${_pkg}"
+pkgdesc="Format shell programs"
+arch=('x86_64' 'i386' 'armv7h' 'aarch64')
+url="https://github.com/mvdan/sh"
license=('BSD')
+depends=('glibc')
provides=('shfmt')
conflicts=('shfmt')
-arch=('x86_64')
-source_x86_64=(
- "https://github.com/mvdan/sh/releases/download/v${pkgver}/shfmt_v${pkgver}_linux_amd64"
- "https://raw.githubusercontent.com/mvdan/sh/v${pkgver}/LICENSE"
-)
-sha256sums_x86_64=(
- 'e582c3417f1b773598c219683a98cc1ce444ca04aef1fa8457c378ad00316b29'
- 'ce63850f77649f00d1394045e2794ffb09a5596beabac51c9548edd958845d7c'
-)
+source=("$pkgname-$pkgver.LICENSE::https://raw.githubusercontent.com/mvdan/sh/v$pkgver/LICENSE")
+_source_base="$pkgname-$pkgver.$_pkgname::$url/releases/download/v$pkgver"
+source_x86_64=("$_source_base/${_pkgname}_v${pkgver}_linux_amd64")
+source_i386=("$_source_base/${_pkgname}_v${pkgver}_linux_386")
+source_armv7h=("$_source_base/${_pkgname}_v${pkgver}_linux_arm")
+source_aarch64=("$_source_base/${_pkgname}_v${pkgver}_linux_arm64")
+
+noextract=("$pkgname-$pkgver.LICENSE" "$pkgname-$pkgver.$_pkgname")
+
+sha256sums=('ce63850f77649f00d1394045e2794ffb09a5596beabac51c9548edd958845d7c')
+sha256sums_x86_64=('5cd7a2b57a0592f919ca2e4249bd567ae3426801a28ae94d0b26f8f2c4ce17f9')
+sha256sums_i386=('5cd7a2b57a0592f919ca2e4249bd567ae3426801a28ae94d0b26f8f2c4ce17f9')
+sha256sums_armv7h=('5cd7a2b57a0592f919ca2e4249bd567ae3426801a28ae94d0b26f8f2c4ce17f9')
+sha256sums_aarch64=('5cd7a2b57a0592f919ca2e4249bd567ae3426801a28ae94d0b26f8f2c4ce17f9')
package() {
- install -Dm755 shfmt_v${pkgver}_linux_amd64 "${pkgdir}/usr/bin/${_name}"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 "$pkgname-$pkgver.$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 "$pkgname-$pkgver.LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}