summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Denisse2019-09-24 17:08:42 -0500
committerAndrea Denisse2019-09-24 17:08:42 -0500
commit917e27db7d3789fc457b2d7c2aef1a97274bf6d2 (patch)
tree92d1a6c1dc960ca7f7fd6a34e3e05cb7725db8b5
downloadaur-917e27db7d3789fc457b2d7c2aef1a97274bf6d2.tar.gz
Created PKGBUILD for shhgit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02147de125af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = shhgit
+ pkgdesc = Find GitHub secrets in real time.
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/eth0izzle/shhgit
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = go-pie
+ provides = shhgit
+ conflicts = shhgit
+ source = shhgit-0.2.tar.gz::https://github.com/eth0izzle/shhgit/archive/v0.2.tar.gz
+ sha256sums = 0cce46f6474f1885b3bce057b8370017248cf3d7a4e16ddb91a6d2c626163680
+
+pkgname = shhgit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30a7b2d7eb0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Andrea 'alephZer0' Gómez <crypto.andrea at protonmail dot ch> -> https://github.com/da-edra
+
+pkgname=shhgit
+pkgver=0.2
+pkgrel=1
+pkgdesc="Find GitHub secrets in real time."
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/eth0izzle/shhgit"
+license=('MIT')
+depends=()
+makedepends=('go-pie')
+provides=("shhgit")
+conflicts=("shhgit")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('0cce46f6474f1885b3bce057b8370017248cf3d7a4e16ddb91a6d2c626163680')
+
+prepare() {
+ export GO111MODULE=on
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ go build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dsm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}