summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2018-08-21 10:44:33 +0000
committerAntonio Rojas2018-08-21 10:44:33 +0000
commit284e42721bec033c034cd48762e9d6b2cd3fae79 (patch)
treef7347cbafb9927efedd9f5ee447abe0fc8171c35
downloadaur-284e42721bec033c034cd48762e9d6b2cd3fae79.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD95
-rw-r--r--support-new-python.diff11
3 files changed, 144 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba54bf314108
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = shiboken
+ pkgver = 1.2.4
+ pkgrel = 4
+ url = http://www.pyside.org
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ makedepends = python2
+ makedepends = python
+ makedepends = qt4
+ makedepends = libxslt
+ source = shiboken-1.2.4.tar.gz::https://github.com/PySide/Shiboken/archive/1.2.4.tar.gz
+ source = support-new-python.diff
+ md5sums = c284197d06ad25d78009ff55f18dd512
+ md5sums = 19d5032866f4e232f442fe19f12b94de
+
+pkgname = python2-shiboken
+ pkgdesc = Support library for Python2 bindings
+ depends = qt4>=4.8
+ depends = libxslt
+ depends = python2
+ depends = shiboken
+
+pkgname = python-shiboken
+ pkgdesc = Support library for Python bindings
+ depends = qt4>=4.8
+ depends = libxslt
+ depends = python
+ depends = shiboken
+
+pkgname = shiboken
+ pkgdesc = CPython bindings generator for C++ libraries
+ depends = python
+ depends = qt4
+ depends = libxslt
+ optdepends = python2-shiboken: for compilation against python2
+ optdepends = python-shiboken: for compilation against python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a1b941af539
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,95 @@
+# Maintainer: Florian Pritz <bluewind@xinu.at>
+# Contributor: Jelle van der Waa <jelle@vdwaa.nl>
+# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
+# Contributor: Matthias Maennich <arch@maennich.net>
+
+pkgbase=shiboken
+pkgname=(python{2,}-shiboken shiboken)
+pkgver=1.2.4
+pkgrel=4
+arch=('x86_64')
+license=('LGPL')
+url="http://www.pyside.org"
+makedepends=('cmake' 'python2' 'python' 'qt4' 'libxslt')
+source=("$pkgbase-$pkgver.tar.gz::https://github.com/PySide/Shiboken/archive/$pkgver.tar.gz"
+ support-new-python.diff)
+md5sums=('c284197d06ad25d78009ff55f18dd512'
+ '19d5032866f4e232f442fe19f12b94de')
+
+prepare(){
+ cd "$srcdir/Shiboken-$pkgver"
+ patch -p1 -i ../support-new-python.diff
+}
+
+build(){
+ cd "$srcdir/Shiboken-$pkgver"
+ # build python2
+ mkdir -p build-py2 && cd build-py2
+ cmake ../ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_TESTS=OFF \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DQT_QMAKE_EXECUTABLE=qmake-qt4
+ make
+
+ # build python3
+ cd "$srcdir/Shiboken-$pkgver"
+ mkdir -p build-py3 && cd build-py3
+ cmake ../ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_TESTS=OFF \
+ -DUSE_PYTHON3=yes \
+ -DQT_QMAKE_EXECUTABLE=qmake-qt4
+ make
+}
+
+package_shiboken() {
+ pkgdesc="CPython bindings generator for C++ libraries"
+ depends=(python qt4 libxslt)
+ optdepends=("python2-shiboken: for compilation against python2"
+ "python-shiboken: for compilation against python")
+
+ # Header files/ /usr/bin/shiboke, pkgconfig, man page
+ cd "$srcdir/Shiboken-$pkgver/build-py3"
+ make DESTDIR="$pkgdir" install
+
+ cd "$srcdir/Shiboken-$pkgver/build-py2"
+ cd data
+ install -Dm 644 ShibokenConfig-python2.7.cmake "$pkgdir/usr/lib/cmake/Shiboken-$pkgver/"
+ install -Dm 644 shiboken.pc "$pkgdir/usr/lib/pkgconfig/shiboken-py2.pc"
+
+ rm -rf "$pkgdir/usr/lib/python"*
+ rm -rf "$pkgdir/usr/lib/libshiboken"*
+ rm -rf "$pkgdir/usr/lib/pkgconfig/"
+ rm "$pkgdir"/usr/lib/cmake/Shiboken-$pkgver/ShibokenConfig*python*.cmake
+}
+package_python2-shiboken() {
+ pkgdesc="Support library for Python2 bindings"
+ depends=("qt4>=4.8" "libxslt" "python2" "shiboken")
+
+ cd "$srcdir/Shiboken-$pkgver/build-py2"
+ make DESTDIR="$pkgdir" install
+
+ cd "$srcdir/Shiboken-$pkgver/build-py2"
+ cd data
+ install -Dm 644 ShibokenConfig-python2.7.cmake "$pkgdir/usr/lib/cmake/Shiboken-$pkgver/"
+ mv "$pkgdir"/usr/lib/pkgconfig/shiboken{,-py2}.pc
+
+ rm -rf "$pkgdir"/usr/{include,bin,share}
+ rm "$pkgdir/usr/lib/cmake/Shiboken-$pkgver/ShibokenConfigVersion.cmake"
+ rm "$pkgdir/usr/lib/cmake/Shiboken-$pkgver/ShibokenConfig.cmake"
+}
+
+package_python-shiboken() {
+ pkgdesc="Support library for Python bindings"
+ depends=("qt4>=4.8" "libxslt" "python" "shiboken")
+
+ cd "$srcdir/Shiboken-$pkgver/build-py3"
+ make DESTDIR="$pkgdir" install
+
+ rm -rf "$pkgdir"/usr/{include,bin,share}
+ rm "$pkgdir/usr/lib/cmake/Shiboken-$pkgver/ShibokenConfigVersion.cmake"
+ rm "$pkgdir/usr/lib/cmake/Shiboken-$pkgver/ShibokenConfig.cmake"
+}
diff --git a/support-new-python.diff b/support-new-python.diff
new file mode 100644
index 000000000000..40eb7d1eaf78
--- /dev/null
+++ b/support-new-python.diff
@@ -0,0 +1,11 @@
+--- a/cmake/Modules/FindPython3Libs.cmake 2014-04-22 23:42:48.000000000 +0800
++++ b/cmake/Modules/FindPython3Libs.cmake 2015-09-21 15:17:27.014598399 +0800
+@@ -27,7 +27,7 @@
+ # Search for the python framework on Apple.
+ # CMAKE_FIND_FRAMEWORKS(Python)
+
+-FOREACH(_CURRENT_VERSION 3.4 3.3 3.2 3.1 3.0)
++FOREACH(_CURRENT_VERSION 3.7 3.6 3.5 3.4 3.3 3.2 3.1 3.0)
+ IF(_CURRENT_VERSION GREATER 3.1)
+ SET(_32FLAGS "m" "u" "mu" "dm" "du" "dmu" "")
+ ELSE()