summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2021-02-09 14:57:58 -0500
committerAndrew Sun2021-02-09 14:57:58 -0500
commit91a3c8f7aa17669fea49d91992974adbee318b8a (patch)
treeaa06f2bde25c7e92be1b4fb4b925ce0bbadcb8dd
parent7518d4f6886ac2b0f4e2c61ffe9d6389c7d5718f (diff)
downloadaur-91a3c8f7aa17669fea49d91992974adbee318b8a.tar.gz
fix for python 3.9
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--support-new-python.diff12
3 files changed, 16 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0f7abcb2385..e1af0bfbc042 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = shiboken
pkgver = 1.2.4
- pkgrel = 7
+ pkgrel = 8
url = http://www.pyside.org
arch = x86_64
license = LGPL
@@ -12,7 +12,7 @@ pkgbase = shiboken
source = shiboken-1.2.4.tar.gz::https://github.com/PySide/Shiboken/archive/1.2.4.tar.gz
source = support-new-python.diff
md5sums = c284197d06ad25d78009ff55f18dd512
- md5sums = 19d5032866f4e232f442fe19f12b94de
+ md5sums = 84844a6459a5fccb3ec2d6418a1af3fd
pkgname = python2-shiboken
pkgdesc = Support library for Python2 bindings
diff --git a/PKGBUILD b/PKGBUILD
index 38297ddf70ee..7b0ff954fef0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=shiboken
pkgname=(python{2,}-shiboken shiboken)
pkgver=1.2.4
-pkgrel=7
+pkgrel=8
arch=('x86_64')
license=('LGPL')
url="http://www.pyside.org"
@@ -15,7 +15,7 @@ makedepends=('cmake' 'python2' 'python' 'qt4' 'libxslt')
source=("$pkgbase-$pkgver.tar.gz::https://github.com/PySide/Shiboken/archive/$pkgver.tar.gz"
support-new-python.diff)
md5sums=('c284197d06ad25d78009ff55f18dd512'
- '19d5032866f4e232f442fe19f12b94de')
+ '84844a6459a5fccb3ec2d6418a1af3fd')
prepare(){
cd "$srcdir/Shiboken-$pkgver"
diff --git a/support-new-python.diff b/support-new-python.diff
index 40eb7d1eaf78..9180d02d524c 100644
--- a/support-new-python.diff
+++ b/support-new-python.diff
@@ -9,3 +9,15 @@
IF(_CURRENT_VERSION GREATER 3.1)
SET(_32FLAGS "m" "u" "mu" "dm" "du" "dmu" "")
ELSE()
+--- a/libshiboken/sbkenum.cpp 2021-02-09 14:52:17.062065563 ->
++++ b/libshiboken/sbkenum.cpp 2021-02-09 14:52:59.965800766 ->
+@@ -529,7 +529,9 @@
+ ::memset(type, 0, sizeof(SbkEnumType));
+ Py_TYPE(type) = &SbkEnumType_Type;
+ type->tp_basicsize = sizeof(SbkEnumObject);
++#ifndef IS_PY3K
+ type->tp_print = &SbkEnumObject_print;
++#endif
+ type->tp_repr = &SbkEnumObject_repr;
+ type->tp_str = &SbkEnumObject_repr;
+ type->tp_flags = Py_TPFLAGS_DEFAULT|Py_TPFLAGS_CHECKTYPES;