summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCebtenzzre2023-05-17 23:54:53 -0400
committerCebtenzzre2023-05-18 00:26:33 -0400
commita125f83098486d992f03feb318d8e7c2f2d9b886 (patch)
tree5ba1f9f27f00e6301759c608aad25747c344c9f8
parent5ebe4a983d33b1d9699d0b693c95018107942875 (diff)
downloadaur-a125f83098486d992f03feb318d8e7c2f2d9b886.tar.gz
update to latest version, depend on older python
The v5.15.3-lts-lgpl tag isn't on any branch, so use the tag directly. Also, set the pkgver to a constant so it's clearer what version is installed. We can't use a simple `git describe` because it reports 5.11.2 for some reason. Depend on an older version of python, since the latest version is not compatible with this version of shiboken2.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 21 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4aebfee1985e..0487ad5687ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,23 @@
pkgbase = shiboken2-git
pkgdesc = Generates bindings for C++ libraries using CPython source code (git version)
- pkgver = r6554.6eb583d7
- pkgrel = 2
+ pkgver = 5.15.3
+ pkgrel = 1
url = https://www.qt.io
arch = x86_64
license = GPL2
license = LGPL
- makedepends = clang
+ makedepends = clang=15.0.7
makedepends = llvm
makedepends = cmake
makedepends = git
makedepends = libxslt
makedepends = qt5-xmlpatterns
- makedepends = python-sphinx
- source = shiboken2-git::git+https://code.qt.io/pyside/pyside-setup.git
+ makedepends = python39
+ source = shiboken2-git::git+https://code.qt.io/pyside/pyside-setup.git#commit=72d32f66685fbb7fefc41eee629e63f4824cb10b
sha256sums = SKIP
pkgname = shiboken2-git
- depends = clang=9.0.1
+ depends = clang=15.0.7
depends = llvm
depends = libxslt
depends = qt5-xmlpatterns
@@ -25,7 +25,6 @@ pkgname = shiboken2-git
conflicts = shiboken2
pkgname = python-shiboken2-git
- depends = python
+ depends = python39
provides = python-shiboken2
conflicts = python-shiboken2
-
diff --git a/PKGBUILD b/PKGBUILD
index 3c58f02f89a5..d61f0079d42e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,23 +8,18 @@
pkgbase=shiboken2-git
pkgname=(shiboken2-git python-shiboken2-git)
-_clangver=9.0.1
-pkgver=r6554.6eb583d7
-pkgrel=2
+_clangver=15.0.7
+pkgver=5.15.3
+pkgrel=1
arch=(x86_64)
url='https://www.qt.io'
license=(GPL2 LGPL)
pkgdesc='Generates bindings for C++ libraries using CPython source code (git version)'
-makedepends=(clang llvm cmake git libxslt qt5-xmlpatterns python-sphinx)
-source=("$pkgbase::git+https://code.qt.io/pyside/pyside-setup.git")
+makedepends=(clang=$_clangver llvm cmake git libxslt qt5-xmlpatterns python39)
+_commit=72d32f66685fbb7fefc41eee629e63f4824cb10b # tags/v5.15.3-lts-lgpl^0
+source=("$pkgbase::git+https://code.qt.io/pyside/pyside-setup.git#commit=$_commit")
sha256sums=('SKIP')
-pkgver() {
- cd "${srcdir}/${pkgname}"
-
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
prepare() {
cd "${srcdir}/${pkgbase}"
@@ -32,13 +27,16 @@ prepare() {
sed -e 's|0307FFFF|0308FFFF|' -i sources/shiboken2/libshiboken/pep384impl.h # Support python 3.8
}
+_python=/usr/bin/python3.9
+
build() {
cd "${srcdir}/${pkgbase}/build"
cmake ../sources/shiboken2 \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_TESTS=OFF \
- -DUSE_PYTHON_VERSION=3
+ -DUSE_PYTHON_VERSION=3 \
+ -DPYTHON_EXECUTABLE=$_python
make
}
@@ -51,15 +49,17 @@ package_shiboken2-git() {
make DESTDIR="$pkgdir" install
# Provided in python-shiboken2
rm -r "$pkgdir"/usr/lib/{python*,libshiboken*}
+# Conflicts with shiboken6 and doesn't work anyway
+ rm "$pkgdir"/usr/bin/shiboken_tool.py
}
package_python-shiboken2-git() {
- depends=(python)
+ depends=(python39)
conflicts=(python-shiboken2)
provides=(python-shiboken2)
cd "${srcdir}/${pkgbase}/build"
make DESTDIR="$pkgdir" install
# Provided in shiboken2
- rm -r "$pkgdir"/usr/{bin,include,lib/{cmake,pkgconfig},share}
+ rm -r "$pkgdir"/usr/{bin,include,lib/{cmake,pkgconfig}}
}