summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2017-08-01 15:05:28 +0800
committerkyechou2017-08-01 15:05:28 +0800
commit397a144e0df8be704c86ef476bb7642fac8cce4a (patch)
tree0179ae7824eb4c89c39101d570387a6549dc0f26
parenteba2a646944e4eb98e9719e2d9d7732b97ccd2ac (diff)
downloadaur-397a144e0df8be704c86ef476bb7642fac8cce4a.tar.gz
add conflicting packages
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c4430461237..5ccc6d90a910 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -38,6 +38,8 @@ pkgname = shifter-runtime
depends = wget
provides = shifter-runtime
conflicts = shifter-slurm-runtime
+ conflicts = shifter-runtime-git
+ conflicts = shifter-slurm-runtime-git
pkgname = shifter-imagegw
install = shifter-imagegw.install
@@ -56,4 +58,6 @@ pkgname = shifter-imagegw
depends = python2-pylint
provides = shifter-imagegw
conflicts = shifter-slurm-imagegw
+ conflicts = shifter-imagegw-git
+ conflicts = shifter-slurm-imagegw-git
diff --git a/PKGBUILD b/PKGBUILD
index 27ead2d2c137..6f6a80d58eb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,7 +47,7 @@ package_shifter-runtime() {
'json-c' 'xfsprogs' 'wget')
install="${pkgname}.install"
provides=('shifter-runtime')
- conflicts=('shifter-slurm-runtime')
+ conflicts=('shifter-slurm-runtime' 'shifter-runtime-git' 'shifter-slurm-runtime-git')
cd "${srcdir}/shifter-${pkgver}_${pkgrel}"
make DESTDIR="${pkgdir}" install
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
@@ -69,7 +69,7 @@ package_shifter-imagegw() {
'python2-redis' 'gunicorn-python2' 'python2-pylint')
install="${pkgname}.install"
provides=('shifter-imagegw')
- conflicts=('shifter-slurm-imagegw')
+ conflicts=('shifter-slurm-imagegw' 'shifter-imagegw-git' 'shifter-slurm-imagegw-git')
cd "${srcdir}/shifter-${pkgver}_${pkgrel}"
make DESTDIR="${pkgdir}" install
install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"