summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaylor Smock2015-08-29 17:44:28 +0000
committerTaylor Smock2015-08-29 17:44:28 +0000
commit3aa0612181d3f04d4e71226d53cacced806bc52f (patch)
tree5c438c26b55974562e4b64eb98946298fcc8a58f
downloadaur-3aa0612181d3f04d4e71226d53cacced806bc52f.tar.gz
Pullover from shim-efi-git and using actual releases
* Using shim 0.9 * Modified Makefile -- looks for some libraries in the wrong place, make complains about recursion
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD60
-rw-r--r--shim.patch24
3 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ab26cbe4c5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = shim-efi
+ pkgdesc = Simple bootloader for x86_64 UEFI Secure Boot - GIT Version
+ pkgver = 0.9
+ pkgrel = 1
+ url = https://github.com/rhinstaller/shim
+ arch = x86_64
+ license = GPL
+ makedepends = gnu-efi-libs
+ depends = pesign
+ depends = dosfstools
+ depends = efivar
+ depends = efibootmgr
+ optdepends = mactel-boot: For bless command in Apple Mac systems
+ provides = shim-efi=0.9
+ provides = shim-efi-x86_64=0.9
+ provides = shim-efi-x86_64-git=0.9
+ conflicts = shim-efi-git
+ conflicts = shim-efi-x86_64
+ conflicts = shim-efi-x86_64-git
+ options = !strip
+ source = https://github.com/rhinstaller/shim/releases/download/0.9/shim-0.9.tar.bz2
+ source = shim.patch
+ md5sums = fc8fb830c0e3eb66f73b0a7872a71279
+ md5sums = 84c5d7dbe5200f0709809f8376cd2004
+
+pkgname = shim-efi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebfca84d7b65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Taylor Smock <vorpalblade77@gmail.com>
+# contributor: Keshav Amburay <(the ddoott ridikulus ddoott rat) (aatt)
+# (gemmaeiil) (ddoott) (ccoomm)>
+
+__pkgname="shim"
+pkgname="${__pkgname}-efi"
+
+pkgver=0.9
+pkgrel=1
+pkgdesc="Simple bootloader for x86_64 UEFI Secure Boot - GIT Version"
+url="https://github.com/rhinstaller/${__pkgname}"
+arch=('x86_64')
+license=('GPL')
+options=('!strip')
+
+makedepends=('gnu-efi-libs')
+depends=('pesign' 'dosfstools' 'efivar' 'efibootmgr')
+optdepends=('mactel-boot: For bless command in Apple Mac systems')
+
+conflicts=("${pkgname}-git" 'shim-efi-x86_64' 'shim-efi-x86_64-git')
+provides=("${pkgname}=${pkgver}" "shim-efi-x86_64=${pkgver}"
+"shim-efi-x86_64-git=${pkgver}")
+
+source=("${url}/releases/download/${pkgver}/${__pkgname}-${pkgver}.tar.bz2"
+ ${__pkgname}.patch)
+md5sums=('fc8fb830c0e3eb66f73b0a7872a71279'
+ '84c5d7dbe5200f0709809f8376cd2004')
+
+prepare() {
+ cd "${srcdir}/${__pkgname}-${pkgver}/"
+
+ patch -i ../${__pkgname}.patch
+}
+
+build() {
+
+ cd "${srcdir}/${__pkgname}-${pkgver}/"
+
+ unset CFLAGS
+ unset CPPFLAGS
+ unset CXXFLAGS
+ unset LDFLAGS
+ unset MAKEFLAGS
+
+ make
+ echo
+
+}
+
+package() {
+
+ cd "${srcdir}/${__pkgname}-${pkgver}/"
+
+ install -d "${pkgdir}/usr/lib/shim/"
+ install -D -m0644 "${srcdir}/${__pkgname}-${pkgver}/shim.efi" "${pkgdir}/usr/lib/shim/shimx64.efi"
+ install -D -m0644 "${srcdir}/${__pkgname}-${pkgver}/MokManager.efi.signed" "${pkgdir}/usr/lib/shim/MokManager.efi.signed"
+ install -D -m0644 "${srcdir}/${__pkgname}-${pkgver}/fallback.efi.signed" "${pkgdir}/usr/lib/shim/fallback.efi.signed"
+
+}
+
diff --git a/shim.patch b/shim.patch
new file mode 100644
index 000000000000..1c65d6ea6e5c
--- /dev/null
+++ b/shim.patch
@@ -0,0 +1,24 @@
+--- Makefile.old 2015-08-29 17:27:15.419529644 +0000
++++ Makefile 2015-08-29 17:30:15.936196950 +0000
+@@ -1,7 +1,7 @@
+ VERSION = 0.9
+ RELEASE :=
+ ifneq ($(RELEASE),"")
+- RELEASE="-$(RELEASE)"
++ RELEASE::="-$(RELEASE)"
+ endif
+
+ CC = $(CROSS_COMPILE)gcc
+@@ -17,10 +17,10 @@
+
+ EFI_INCLUDE := /usr/include/efi
+ EFI_INCLUDES = -nostdinc -ICryptlib -ICryptlib/Include -I$(EFI_INCLUDE) -I$(EFI_INCLUDE)/$(ARCH) -I$(EFI_INCLUDE)/protocol -I$(shell pwd)/include
+-EFI_PATH := /usr/lib64/gnuefi
++EFI_PATH := /usr/lib64
+
+ LIB_GCC = $(shell $(CC) -print-libgcc-file-name)
+-EFI_LIBS = -lefi -lgnuefi --start-group Cryptlib/libcryptlib.a Cryptlib/OpenSSL/libopenssl.a --end-group $(LIB_GCC)
++EFI_LIBS = -lefi -lgnuefi --start-group Cryptlib/libcryptlib.a Cryptlib/OpenSSL/libopenssl.a --end-group $(LIB_GCC)
+
+ EFI_CRT_OBJS = $(EFI_PATH)/crt0-efi-$(ARCH).o
+ EFI_LDS = elf_$(ARCH)_efi.lds