summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2021-03-09 23:23:37 +0100
committerJonas Witschel2021-03-09 23:23:37 +0100
commitda61f40425c0481c8ecf6aa0952c90c9b8658525 (patch)
treed5e4d9ea48a799df0567d87829e623e3015b7b26
parentd16cfc421060855b8e6693ba5e483d66166599b3 (diff)
downloadaur-da61f40425c0481c8ecf6aa0952c90c9b8658525.tar.gz
upgpkg: shim-efi-git 15.r204.758b795a-1: disable buildflags, add gnu-efi submodule
- Upstream is back at using vendored libraries, this time for gnu-efi :( - Building with the default Arch Linux buildflags fails with the following error, so disable them (they are not very meaningful for EFI binaries anyway): /build/shim-efi-git/src/shim/gnu-efi//lib/print.c: In function ‘_Print’: /build/shim-efi-git/src/shim/gnu-efi//lib/print.c:1242:17: error: SSE register argument with SSE disabled 1242 | FloatToString ( | ^~~~~~~~~~~~~~~ 1243 | Item.Scratch, | ~~~~~~~~~~~~~ 1244 | Item.Comma, | ~~~~~~~~~~~ 1245 | va_arg(ps->args, double) | ~~~~~~~~~~~~~~~~~~~~~~~~ 1246 | ); | ~
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14957d01cfce..fd839b026b37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = shim-efi-git
pkgdesc = UEFI shim loader
- pkgver = 15.r190.9c48fc3e
+ pkgver = 15.r204.758b795a
pkgrel = 1
url = https://github.com/rhboot/shim
arch = x86_64
@@ -9,7 +9,10 @@ pkgbase = shim-efi-git
makedepends = gnu-efi
provides = shim-efi
conflicts = shim-efi
+ options = !buildflags
source = git+https://github.com/rhboot/shim.git#branch=main
+ source = rhboot-gnu-efi::git+https://github.com/rhboot/gnu-efi.git
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = shim-efi-git
diff --git a/PKGBUILD b/PKGBUILD
index b31a11a5a7dd..aab1927a0328 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Keshav Amburay <(the ddoott ridikulus ddoott rat) (aatt) (gemmaeiil) (ddoott) (ccoomm)>
# Contributor: Pablo Lezaeta <(prflr 88) (arro'a) (gmail) (puntocom)>
pkgname=shim-efi-git
-pkgver=15.r190.9c48fc3e
+pkgver=15.r204.758b795a
pkgrel=1
pkgdesc='UEFI shim loader'
arch=('x86_64')
@@ -11,8 +11,11 @@ license=('BSD')
makedepends=('git' 'gnu-efi')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git+$url.git#branch=main")
-sha512sums=('SKIP')
+options=('!buildflags')
+source=("git+$url.git#branch=main"
+ 'rhboot-gnu-efi::git+https://github.com/rhboot/gnu-efi.git')
+sha512sums=('SKIP'
+ 'SKIP')
pkgver() {
cd shim
@@ -21,6 +24,10 @@ pkgver() {
prepare() {
cd shim
+ git submodule init
+ git config submodule.gnu-efi.url "$srcdir/rhboot-gnu-efi"
+ git submodule update
+
sed -e 's/-Werror //g' -i Makefile Make.defaults
}