summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornl67202021-07-18 18:25:16 +0300
committernl67202021-07-18 18:25:16 +0300
commitc5c8e94ea887a29f371b8fbc3a78a66cc6646a9b (patch)
treed58d27cdf9a364a74e775e35960c5faeb1c9e398
parent06c5dcafdc3e917f93e2adc45eaeba8cf21a80fe (diff)
downloadaur-c5c8e94ea887a29f371b8fbc3a78a66cc6646a9b.tar.gz
shim-signed 15.4+fedora+5-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
-rw-r--r--shim-signed.install13
3 files changed, 28 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17768e2ba84a..41ebacd7290d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = shim-signed
- pkgdesc = Initial UEFI bootloader that handles chaining to a trusted full bootloader under secure boot environments (prebuilt X64 EFI binaries from Debian)
- pkgver = 15.r2.debian+15+1533136590.3beb971+7+deb10u1
+ pkgdesc = Initial UEFI bootloader that handles chaining to a trusted full bootloader under secure boot environments (prebuilt X64 EFI binaries from Fedora)
+ pkgver = 15.4+fedora+5
pkgrel = 1
- url = https://packages.debian.org/buster/shim-signed
+ url = https://koji.fedoraproject.org/koji/packageinfo?packageID=14502
+ install = shim-signed.install
arch = any
license = BSD
- noextract = shim-helpers-amd64-signed_1+15+1533136590.3beb971+7+deb10u1_amd64.deb
options = !strip
- source = https://deb.debian.org/debian/pool/main/s/shim-signed/shim-signed_1.33+15+1533136590.3beb971-7_amd64.deb
- source = https://deb.debian.org/debian/pool/main/s/shim-helpers-amd64-signed/shim-helpers-amd64-signed_1+15+1533136590.3beb971+7+deb10u1_amd64.deb
- sha256sums = da466858eee1786433646dfcc9918395d2da06a7fb1815a3f66de749f5d8e506
- sha256sums = 5d9198a417a4e0692e68d04594df1717ea10e9f80eb8292f19d30c56ab34a100
+ source = https://kojipkgs.fedoraproject.org/packages/shim/15.4/5/x86_64/shim-x64-15.4-5.x86_64.rpm
+ sha512sums = 966836d71ad4b6cca44e650893aeb09e69d1ca9d192d61a8b9efef8d7389b2a6e0ff0f488c3c00dd895427ac2ae1a4778e62d39340d7bd0ff9e809a45cebd014
pkgname = shim-signed
diff --git a/PKGBUILD b/PKGBUILD
index ed598dd5c342..6d6c6dcfb48e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,19 @@
# Maintainer: nl6720 <nl6720@archlinux.org>
pkgname='shim-signed'
-pkgver='15.r2.debian+15+1533136590.3beb971+7+deb10u1'
+pkgver='15.4+fedora+5'
pkgrel='1'
-pkgdesc='Initial UEFI bootloader that handles chaining to a trusted full bootloader under secure boot environments (prebuilt X64 EFI binaries from Debian)'
-url='https://packages.debian.org/buster/shim-signed'
+pkgdesc='Initial UEFI bootloader that handles chaining to a trusted full bootloader under secure boot environments (prebuilt X64 EFI binaries from Fedora)'
+url='https://koji.fedoraproject.org/koji/packageinfo?packageID=14502'
arch=('any')
license=('BSD')
options=('!strip')
-noextract=('shim-helpers-amd64-signed_1+15+1533136590.3beb971+7+deb10u1_amd64.deb')
-source=('https://deb.debian.org/debian/pool/main/s/shim-signed/shim-signed_1.33+15+1533136590.3beb971-7_amd64.deb'
- 'https://deb.debian.org/debian/pool/main/s/shim-helpers-amd64-signed/shim-helpers-amd64-signed_1+15+1533136590.3beb971+7+deb10u1_amd64.deb')
-sha256sums=('da466858eee1786433646dfcc9918395d2da06a7fb1815a3f66de749f5d8e506'
- '5d9198a417a4e0692e68d04594df1717ea10e9f80eb8292f19d30c56ab34a100')
-prepare() {
- cd "$srcdir"
- # Exctract shimx64.efi
- bsdtar -xf 'data.tar.xz' 'usr/lib/shim/'
- # Extract mmx64.efi and fbx64.efi
- bsdtar -xf 'shim-helpers-amd64-signed_1+15+1533136590.3beb971+7+deb10u1_amd64.deb' 'data.tar.xz'
- bsdtar -xf 'data.tar.xz' 'usr/lib/shim/'
-}
+install="${pkgname}.install"
+source=("https://kojipkgs.fedoraproject.org/packages/shim/${pkgver//+fedora+/\/}/x86_64/shim-x64-${pkgver//+fedora+/-}.x86_64.rpm")
+sha512sums=('966836d71ad4b6cca44e650893aeb09e69d1ca9d192d61a8b9efef8d7389b2a6e0ff0f488c3c00dd895427ac2ae1a4778e62d39340d7bd0ff9e809a45cebd014')
package() {
- install -Dm0644 "${srcdir}/usr/lib/shim/shimx64.efi.signed" "${pkgdir}/usr/share/${pkgname}/shimx64.efi"
- install -Dm0644 "${srcdir}/usr/lib/shim/mmx64.efi.signed" "${pkgdir}/usr/share/${pkgname}/mmx64.efi"
- install -Dm0644 "${srcdir}/usr/lib/shim/fbx64.efi.signed" "${pkgdir}/usr/share/${pkgname}/fbx64.efi"
+ install -D -m0644 -t "${pkgdir}/usr/share/${pkgname}/" "${srcdir}/boot/efi/EFI/fedora/shimx64.efi"
+ install -D -m0644 -t "${pkgdir}/usr/share/${pkgname}/" "${srcdir}/boot/efi/EFI/fedora/mmx64.efi"
+ install -D -m0644 -t "${pkgdir}/usr/share/${pkgname}/" "${srcdir}/boot/efi/EFI/BOOT/fbx64.efi"
}
diff --git a/shim-signed.install b/shim-signed.install
new file mode 100644
index 000000000000..ed3951a8aef4
--- /dev/null
+++ b/shim-signed.install
@@ -0,0 +1,13 @@
+post_install() {
+ cat <<EOF
+ WARNING: Since version 15.3, shim requires SBAT.
+ It WILL NOT launch EFI binaries without a .sbat section.
+ See the upstream documentation: https://github.com/rhboot/shim/blob/main/SBAT.md
+EOF
+}
+
+post_upgrade() {
+ if (( $(vercmp $1 15.4+fedora+5) <= 0)); then
+ post_install
+ fi
+}