summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIntegral2022-09-19 13:54:12 +0800
committerIntegral2022-09-19 13:54:12 +0800
commitb674732fca4eaea296d9f08ed80a3c9046a6d3f2 (patch)
tree8be3bd3b5de1b5ee1d575c3883de030f516e6040
downloadaur-b674732fca4eaea296d9f08ed80a3c9046a6d3f2.tar.gz
release
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4e179c5214c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = shimo-bin
+ pkgdesc = 石墨文档 Shimo document (An online collaborative office software).
+ pkgver = 3.0.4
+ pkgrel = 1
+ url = https://shimo.im/
+ arch = x86_64
+ license = custom
+ depends = nss
+ depends = alsa-lib
+ depends = java-runtime
+ depends = libnet
+ depends = gtk3
+ depends = libxkbcommon-x11
+ source = https://as.smvm.cn/panther/shimo/release/linux/x64/shimo_v3.0.4-release.98ec8bb.shimo_linux-amd64.deb
+ sha512sums = ccebe1e6e8be1b6292a59c21aee5b24fae8ced93e6abb4f60850af9bb74696f816368224d886a979c245963ee2a20c737c89677c552af3c2574f7827b7e62aec
+
+pkgname = shimo-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7dc191e99506
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*.zst
+/*.zip
+/*.deb
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68c151f000e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer:Integral<luckys68@126.com>
+pkgname=shimo-bin
+_pkgname=shimo
+pkgver=3.0.4
+pkgrel=1
+pkgdesc="石墨文档 Shimo document (An online collaborative office software)."
+arch=('x86_64')
+url="https://shimo.im/"
+license=('custom')
+depends=('nss' 'alsa-lib' 'java-runtime' 'libnet' 'gtk3' 'libxkbcommon-x11')
+source=(
+ "https://as.smvm.cn/panther/shimo/release/linux/x64/shimo_v${pkgver}-release.98ec8bb.shimo_linux-amd64.deb"
+)
+sha512sums=('ccebe1e6e8be1b6292a59c21aee5b24fae8ced93e6abb4f60850af9bb74696f816368224d886a979c245963ee2a20c737c89677c552af3c2574f7827b7e62aec')
+
+package() {
+ echo " -> Extracting the data.tar.gz..."
+ bsdtar -xvf data.tar.gz -C "${pkgdir}/"
+ chmod -R 755 "${pkgdir}/"
+
+ echo " -> Installing..."
+ # Launcher
+ mkdir -p "${pkgdir}/usr/bin/"
+ ln -s "/opt/${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ # License
+ install -Dm644 "${pkgdir}/opt/shimo/LICENSE.electron.txt" -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dm644 "${pkgdir}/opt/shimo/LICENSES.chromium.html" -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+}