summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Vuillard2015-06-22 15:13:58 +0200
committerArthur Vuillard2015-06-22 15:13:58 +0200
commit5cee90e10a3afc3ed8ad9df088c22e6e5914e975 (patch)
treed73d4cf659912a580ce8831917ad2ab23059f500
parentd19a71c4cb568c5d3206b9591b8f3c635f3ac013 (diff)
downloadaur-5cee90e10a3afc3ed8ad9df088c22e6e5914e975.tar.gz
debug of packaging, update .SRCINFO
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--default134
3 files changed, 148 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6ee5e012dae..ec3a87bd608c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = shinken
pkgdesc = An open source Nagios like tool, redesigned and rewritten from scratch. Its main goal is to meet today's system monitoring requirements while still following compatibility to Nagios
- pkgver = 2.2
+ pkgver = 2.4
pkgrel = 2
url = http://www.shinken-monitoring.org/
install = shinken.install
@@ -76,7 +76,9 @@ pkgbase = shinken
backup = etc/shinken/commands/notify-host-by-xmpp.cfg
backup = etc/shinken/commands/notify-service-by-xmpp.cfg
backup = etc/shinken/receivers/receiver-master.cfg
- source = https://pypi.python.org/packages/source/S/Shinken/Shinken-2.2.tar.gz
+ backup = etc/default/shinken
+ backup = etc/logrotate.d/shinken
+ source = https://github.com/naparuba/shinken/archive/2.4.tar.gz
source = shinken-arbiter.service
source = shinken-broker.service
source = shinken.install
@@ -86,7 +88,8 @@ pkgbase = shinken
source = shinken-receiver.service
source = shinken-scheduler.service
source = shinken.tmpfiles
- sha256sums = 72d7beb296cf7dad6084b8b788eef91818c61567bcf6745ad749c3fd31c4e5c4
+ source = default
+ sha256sums = b5734a5764aec89ae0286d505bb9f260b6ee1aa3b6fa1d9ef20fd261fe6def8b
sha256sums = efa31d6bac681f6e994f5a0544ecaa5ab044099057d5e75d2e6b41e9e69f361f
sha256sums = 845315a7eb1b1a3f7fca8051b1470d28b5e9950ce55cda17bf2d0a7bc4a1e644
sha256sums = 86dcb7112517110c6fc4f47070e8f217d45185ce2ceab1b9d69653f3870577c2
@@ -96,6 +99,7 @@ pkgbase = shinken
sha256sums = eaf9ca44e8d4a1589d694ea9341ad91c41306a6c0038d5fa7a41e36556cfafff
sha256sums = b4d80c1b54dfa5890d4a9e68622e197444aa8c6132d003b7ddd12ae9b2a15615
sha256sums = 02bfb59fdfdbfd3f55ef8a32c2b7c70f340d4db604a8d3bf7b22825632f0584d
+ sha256sums = 3cfb0d927acc802cbaadd1031da215df7250784f8ace99e18c53ba36423b7411
pkgname = shinken
diff --git a/PKGBUILD b/PKGBUILD
index 2f7af9ba04b8..0db0d5918341 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=shinken
pkgver=2.4
-pkgrel=1
+pkgrel=2
pkgdesc="An open source Nagios like tool, redesigned and rewritten from scratch. Its main goal is to meet today's system monitoring requirements while still following compatibility to Nagios"
arch=('any')
url='http://www.shinken-monitoring.org/'
@@ -96,6 +96,7 @@ source=(
"shinken-receiver.service"
"shinken-scheduler.service"
"shinken.tmpfiles"
+ "default"
)
prepare() {
@@ -119,11 +120,12 @@ package() {
cd "$srcdir/shinken-${pkgver}"
mkdir -p $pkgdir/usr/lib/python2.7/site-packages/
- cp -r build/bdist.linux-x86_64/egg/shinken $pkgdir/usr/lib/python2.7/site-packages/
+ cp -r build/lib/shinken $pkgdir/usr/lib/python2.7/site-packages/
mkdir -p $pkgdir/etc/default
cp -r etc/ $pkgdir/etc/shinken/
- cp build/bin/default/shinken $pkgdir/etc/default/shinken
+
+ cp $srcdir/default $pkgdir/etc/default/shinken
mkdir -p $pkgdir/usr/bin
BINFILES=`ls bin/shinken* | grep -v "\.py$"`
@@ -163,5 +165,6 @@ sha256sums=('b5734a5764aec89ae0286d505bb9f260b6ee1aa3b6fa1d9ef20fd261fe6def8b'
'8c2bdcc3af62f06a2f8168fb9eef74d65a931fba8be91a4947edc7d3e93666b1'
'eaf9ca44e8d4a1589d694ea9341ad91c41306a6c0038d5fa7a41e36556cfafff'
'b4d80c1b54dfa5890d4a9e68622e197444aa8c6132d003b7ddd12ae9b2a15615'
- '02bfb59fdfdbfd3f55ef8a32c2b7c70f340d4db604a8d3bf7b22825632f0584d')
+ '02bfb59fdfdbfd3f55ef8a32c2b7c70f340d4db604a8d3bf7b22825632f0584d'
+ '3cfb0d927acc802cbaadd1031da215df7250784f8ace99e18c53ba36423b7411')
diff --git a/default b/default
new file mode 100644
index 000000000000..a0616fb37918
--- /dev/null
+++ b/default
@@ -0,0 +1,134 @@
+# Copyright (C) 2009-2014:
+# Gabes Jean, naparuba@gmail.com
+# Gerhard Lausser, Gerhard.Lausser@consol.de
+# Gregory Starck, g.starck@gmail.com
+# Hartmut Goebel, h.goebel@goebel-consult.de
+#
+# This file is part of Shinken.
+#
+# Shinken is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# Shinken is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with Shinken. If not, see <http://www.gnu.org/licenses/>.
+
+
+# /etc/default/shinken
+# /etc/shinken is where we put all configuration files
+# /var/lib/shinken/ is where we put some variables files (replaced by /var/run/shinken and /var/log/shinken for now)
+# /var/run/shinken is where we put pid files
+# /var/log/shinken is where we put log files
+# /usr/bin is where the launch scripts will be send
+
+
+## These vars will override the hardcoded ones in init script ##
+ETC=/etc/shinken
+VAR=/var/lib/shinken/
+BIN=/usr/bin
+RUN=/var/run/shinken
+LOG=/var/log/shinken
+
+
+### ARBITER PART ###
+# location of the shinken configuration file
+# Please update /etc/shinken instead of this one.
+SHINKENCFG="$ETC/shinken.cfg"
+
+# We got 2 configs because tools like Centreon don't generate all
+# configuration (only the shinken.cfg part)
+#SHINKENSPECIFICCFG="$ETC/shinken-specific.cfg"
+
+# The command to launch
+ARBITERDAEMON=$BIN/shinken-arbiter
+
+#The ARBITER PID
+if [ -r $SHINKENCFG ] ; then
+ tmppid=`grep 'lock_file=' $SHINKENCFG | grep -v '#' | tail -n 1 | awk -F '=' '{print $2}'`
+ ARBITERPID=${tmppid-$RUN/arbiterd.pid}
+else
+ ARBITERPID="$RUN/arbiterd.pid"
+fi
+
+ARBITERDEBUGFILE="$LOG/arbiter-debug.log"
+
+
+### SCHEDULER PART ###
+# location of the scheduler daemon configuration
+SCHEDULERCFG="$ETC/daemons/schedulerd.ini"
+
+# The command to launch
+SCHEDULERDAEMON=$BIN/shinken-scheduler
+
+# The SCHEDULER PID
+SCHEDULERPID="$RUN/schedulerd.pid"
+
+SCHEDULERDEBUGFILE="$LOG/scheduler-debug.log"
+
+
+### POLLER PART ###
+# location of the poller daemon configuration
+POLLERCFG="$ETC/daemons/pollerd.ini"
+
+# The command to launch
+POLLERDAEMON=$BIN/shinken-poller
+
+# The poller pid
+POLLERPID="$RUN/pollerd.pid"
+
+POLLERDEBUGFILE="$LOG/poller-debug.log"
+
+
+### REACTIONNER PART ###
+# location of the reactionner daemon configuration
+REACTIONNERCFG="$ETC/daemons/reactionnerd.ini"
+
+# The command to launch
+REACTIONNERDAEMON=$BIN/shinken-reactionner
+
+#The reactionner pid
+REACTIONNERPID="$RUN/reactionnerd.pid"
+
+REACTIONNERDEBUGFILE="$LOG/reactionner-debug.log"
+
+
+### BROKER PART ###
+# location of the broker daemon configuration
+BROKERCFG="$ETC/daemons/brokerd.ini"
+
+# The command to launch
+BROKERDAEMON=$BIN/shinken-broker
+
+# The broker pid
+BROKERPID="$RUN/brokerd.pid"
+
+BROKERDEBUGFILE="$LOG/broker-debug.log"
+
+
+### RECEIVER PART ###
+# location of the broker receiver configuration
+RECEIVERCFG="$ETC/daemons/receiverd.ini"
+
+# The command to launch
+RECEIVERDAEMON=$BIN/shinken-receiver
+
+#The receiver pid
+RECEIVERPID="$RUN/receiverd.pid"
+
+RECEIVERDEBUGFILE="$LOG/receiver-debug.log"
+
+
+
+# nicelevel to run shinken daemon with
+NICENESS=5
+
+# user/group for the var/run rights
+#SHINKENUSER=shinken
+#SHINKENGROUP=shinken
+#HOME=`grep ^$SHINKENUSER: /etc/passwd | cut -d: -f 6`