summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Martin2017-08-15 16:08:10 -0500
committerStephen Martin2017-08-15 16:08:10 -0500
commitcdf06c21c071b966c2dc83cd14f63cb796ee98e6 (patch)
tree237f024bf0b879ea0598bcedb61822e003ce978d
parentdf5105ea47e4d7c78ea3806d3adbb51f6504088a (diff)
downloadaur-cdf06c21c071b966c2dc83cd14f63cb796ee98e6.tar.gz
Fixed build error. Forcing gcc5
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07400d99b60e..3f0d25c27188 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Oct 20 01:31:03 UTC 2016
+# Tue Aug 15 21:07:34 UTC 2017
pkgbase = shiny-server-git
pkgdesc = Open-source version of the shiny web development framework server
pkgver = 20160223
@@ -13,8 +13,9 @@ pkgbase = shiny-server-git
makedepends = python2
makedepends = cmake
makedepends = r
+ makedepends = gcc5
depends = r
- backup = etc/shiny-server.conf
+ backup = etc/shiny-server/shiny-server.conf
source = shiny-server::git+https://github.com/rstudio/shiny-server.git
source = shiny-server.service
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ec8df3a5caf2..1416e54ab1a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,9 @@ arch=('i686' 'x86_64')
url="http://www.rstudio.com/shiny/server/install-opensource"
license=('AGPL')
depends=('r')
-makedepends=('git' 'python2' 'cmake' 'r')
+makedepends=('git' 'python2' 'cmake' 'r' 'gcc5')
install='accounts.install'
-backup=('etc/shiny-server.conf')
+backup=('etc/shiny-server/shiny-server.conf')
source=('shiny-server::git+https://github.com/rstudio/shiny-server.git'
'shiny-server.service')
pkver(){
@@ -20,6 +20,7 @@ pkver(){
_gitroot=https://github.com/rstudio/shiny-server.git
_gitname=shiny-server
prepare(){
+ # Vigorously force the use of python2
cd $srcdir
find -type f -exec sed \
-e 's_^#!/usr/bin/env python$_&2_' \
@@ -32,18 +33,24 @@ build() {
cd "$srcdir/$_gitname"
mkdir tmp
cd tmp
+ # More python2 hackery
DIR=`pwd`
PATH=$DIR/../bin/:$PATH
ln -s `which python2` ../bin/python
export _PYTHON=`which python2`
-
export PYTHON=`which python2`
+
+ # Node fails with gcc7
+ export CC=/bin/gcc-5
+ export CXX=/bin/g++-5
+
+ # CMake
cmake -DCMAKE_INSTALL_PREFIX=/usr -DPYTHON="$_PYTHON" ../
make
mkdir ../build
(cd .. && bin/npm --python="$PYTHON" install)
- (cd .. && ext/node/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js --python="$PYTHON" rebuild)
+ (cd .. && bin/node ext/node/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js --python="$PYTHON" rebuild)
}
package() {