summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortorculus2024-03-19 07:04:02 -0400
committertorculus2024-03-19 07:04:02 -0400
commit1dc0407ded6b8afacb8200f4d0dbec9d797d3697 (patch)
treeee6919f2e31614eb1bab7f65420119b5b010c6d7
parente4aa443cd62473ccaf21deac3f433b413ccfa6be (diff)
downloadaur-1dc0407ded6b8afacb8200f4d0dbec9d797d3697.tar.gz
upgpkg: shiori 1.6.0-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD46
2 files changed, 26 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a8fcb26afd2..abd257d497b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = shiori
- pkgdesc = Simple bookmark manager
- pkgver = 1.5.5
+ pkgdesc = Simple bookmark manager built with Go
+ pkgver = 1.6.0
pkgrel = 1
url = https://github.com/go-shiori/shiori
arch = x86_64
+ arch = armv7h
+ arch = aarch64
license = MIT
- makedepends = git
makedepends = go
depends = glibc
+ provides = shiori
+ conflicts = shiori-bin
options = !lto
- source = shiori::git+https://github.com/go-shiori/shiori.git#commit=e7faeaf2ce79e9588995bac2dd05099d916b929b
+ source = https://github.com/go-shiori/shiori/archive/refs/tags/v1.6.0.tar.gz
source = systemd.service
source = sysusers.conf
source = tmpfiles.conf
diff --git a/PKGBUILD b/PKGBUILD
index 3c57bcc2e41c..873bc72c61ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: George Rawlinson <grawlinson@archlinux.org>
-
+# Maintainer: torculus <20175597+torculus@users.noreply.github.com>
+# Contributor: George Rawlinson <grawlinson@archlinux.org>
pkgname=shiori
-pkgver=1.5.5
+pkgver=1.6.0
pkgrel=1
-pkgdesc='Simple bookmark manager'
-arch=('x86_64')
+pkgdesc='Simple bookmark manager built with Go'
+arch=('x86_64' 'armv7h' 'aarch64')
url='https://github.com/go-shiori/shiori'
license=('MIT')
+provides=('shiori')
+conflicts=('shiori-bin')
depends=('glibc')
-makedepends=('git' 'go')
+makedepends=('go')
options=('!lto')
-_commit='e7faeaf2ce79e9588995bac2dd05099d916b929b'
source=(
- "$pkgname::git+$url.git#commit=$_commit"
+ "${url}/archive/refs/tags/v$pkgver.tar.gz"
'systemd.service'
'sysusers.conf'
'tmpfiles.conf'
@@ -26,37 +27,28 @@ b2sums=('SKIP'
'4a0fe59a05aa1275a3e42bf616ef4f9c0e2ca3639a516f6966ef1689ff20f6e84827ca43ab66e15f31c9628c452a274d5a888f45155100b851fdcecd5c327fe7'
'1a119411823ab3f6a49ab66c9df7bcad747d594c95aa96918f3f416481ee791533e67ae9789232e7806bd4178d2af18f88c7cc5a1ac06daa3678c7a37adb175a')
-pkgver() {
- cd "$pkgname"
-
- git describe --tags | sed 's/^v//'
-}
-
prepare() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
# create directory for build output
- mkdir build
+ mkdir -p build/
# download dependencies
go mod download
}
build() {
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
# set Go flags
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
+ export GOOS="linux"
- go build -v \
- -trimpath \
- -buildmode=pie \
- -mod=readonly \
- -modcacherw \
- -ldflags "-linkmode external -extldflags ${LDFLAGS}" \
- -o build \
- .
+ go build -o build ./...
# shell completions
for shell in bash fish zsh; do
@@ -65,7 +57,7 @@ build() {
}
#check() {
-# cd "$pkgname"
+# cd "$pkgname-$pkgver"
#
# go test -v ./...
#}
@@ -76,7 +68,7 @@ package() {
install -vDm644 sysusers.conf "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
install -vDm644 tmpfiles.conf "$pkgdir/usr/lib/tmpfiles.d/$pkgname.conf"
- cd "$pkgname"
+ cd "$pkgname-$pkgver"
# binary
install -vDm755 -t "$pkgdir/usr/bin" build/shiori