summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-06-01 03:38:50 +0200
committerChristopher Arndt2020-06-01 03:38:50 +0200
commit7243bcc35e23a43c2817ec07108ab6a7a677361a (patch)
tree1500d7b090d3f5639c4d83697887b5d4c3d84f73
downloadaur-7243bcc35e23a43c2817ec07108ab6a7a677361a.tar.gz
New VCS package 'shiro-plugins-git'
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD59
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21d0c2a4ed4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = shiro-plugins-git
+ pkgdesc = Collection of LADSPA, LV2 and VST2 plugins made in MAX Gen~ (no MOD UI) (git version)
+ pkgver = 0.1.0.r37.138d49a
+ pkgrel = 1
+ url = https://github.com/ninodewit/SHIRO-Plugins/
+ arch = i686
+ arch = x86_64
+ groups = pro-audio
+ groups = lv2-plugins
+ groups = vst-plugins
+ license = GPL3
+ makedepends = git
+ depends = gcc-libs
+ provides = shiro-plugins
+ provides = shiro-plugins=0.1.0
+ conflicts = shiro-plugins
+ source = shiro-plugins::git+https://github.com/ninodewit/SHIRO-Plugins.git
+ source = dpf::git+https://github.com/DISTRHO/DPF.git
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = shiro-plugins-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..51d95c61e44f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+dpf/
+shiro-plugins/
+pkg/
+src/
+shiro-plugins-git-*.tar.xz
+shiro-plugins-git-*.tar.zst
+shiro-plugins-git-*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4381157c8471
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_pkgname=shiro-plugins
+pkgname="${_pkgname}-git"
+pkgver=0.1.0.r37.138d49a
+pkgrel=1
+pkgdesc="Collection of LADSPA, LV2 and VST2 plugins made in MAX Gen~ (no MOD UI) (git version)"
+arch=('i686' 'x86_64')
+url="https://github.com/ninodewit/SHIRO-Plugins/"
+license=('GPL3')
+depends=('gcc-libs')
+makedepends=('git')
+groups=('pro-audio' 'lv2-plugins' 'vst-plugins')
+provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/ninodewit/SHIRO-Plugins.git"
+ 'dpf::git+https://github.com/DISTRHO/DPF.git')
+md5sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ # project has no release yet so we'll use the version number from the common plugin code
+ local ver="$(grep d_version plugins/common/DistrhoPluginMaxGen.hpp | sed -E 's/\s+return d_version\(([0-9]), ([0-9]), ([0-9])\);\s?/\1.\2.\3/')"
+ echo "$ver.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ git submodule init
+ git config submodule.dpf.url "${srcdir}/dpf"
+ git submodule update
+
+ # we disable the mod UI so the plugins can be used any DAW
+ for header in plugins/*/DistrhoPluginInfo.h; do
+ sed -E -i 's/DISTRHO_PLUGIN_USES_MODGUI\s+1/DISTRHO_PLUGIN_USES_MODGUI 0/' "$header";
+ done
+
+ # don't install empty DSSI directoy
+ sed -i '/dssi/d' Makefile
+
+ # fix license identifier in plugin meta data
+ sed -i 's|"ISC"|"https://spdx.org/licenses/GPL-3.0-only"|' \
+ plugins/common/DistrhoPluginMaxGen.hpp
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ ./scripts/update-generated-code.sh
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ make DESTDIR="${pkgdir}" PREFIX=/usr install
+}