summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2020-03-15 17:01:21 +0000
committerMilk Brewster2020-03-15 17:01:21 +0000
commitf5f988daeb531b04b8520ba38ea8aa1a473ee2e4 (patch)
treed1da8c052a408f6c3a7b26c3edc7224f76e5d57e
downloadaur-f5f988daeb531b04b8520ba38ea8aa1a473ee2e4.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD49
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..760658c05915
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = shiru.lv2-git
+ pkgdesc = A set of music plugins created by Shiru, unofficial DPF ports
+ pkgver = r46.08853f9
+ pkgrel = 1
+ url = https://github.com/linuxmao-org/shiru-plugins
+ arch = x86_64
+ license = GPL
+ source = shiru.lv2-git::git+https://github.com/linuxmao-org/shiru-plugins
+ md5sums = SKIP
+
+pkgname = shiru.lv2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8c5070a146e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Milkii Brewster <milkii on Freenode IRC>
+pkgname=shiru.lv2-git
+pkgdesc="A set of music plugins created by Shiru, unofficial DPF ports"
+pkgver=r46.08853f9
+pkgrel=1
+epoch=
+arch=(x86_64)
+url="https://github.com/linuxmao-org/shiru-plugins"
+license=(GPL)
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(shiru.lv2-git::git+https://github.com/linuxmao-org/shiru-plugins)
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "$pkgname"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$pkgname"
+ # ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p ${pkgdir}/usr/lib/lv2
+ mv bin/*.lv2/ ${pkgdir}/usr/lib/lv2
+}