summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranc[e]sco2018-09-10 17:00:26 +0200
committerFranc[e]sco2018-09-10 17:00:26 +0200
commitf6e79fb8625fdb00e71e6921137eb395c30af62e (patch)
tree6bd3edf4e528dd5df9efe8a3110bfc1d4da94242
downloadaur-f6e79fb8625fdb00e71e6921137eb395c30af62e.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b56c9a073f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = shmupmametgm
+ pkgdesc = Customized MAME for the TGM series. Forked for extra output options and tooling.
+ pkgver = r79.5ac496e
+ pkgrel = 1
+ url = https://github.com/MaryHal/shmupmametgm
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = sdl
+ depends = gconf
+ source = git+https://github.com/MaryHal/shmupmametgm.git
+ sha256sums = SKIP
+
+pkgname = shmupmametgm
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bd4da58c0b87
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.xz
+/src
+/pkg
+/shmupmametgm
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81bfd3ddafe4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Franc[e]sco <lolisamurai@tfwno.gf>
+
+pkgname=shmupmametgm
+pkgver=r79.5ac496e
+pkgrel=1
+pkgdesc="Customized MAME for the TGM series. Forked for extra output options and tooling."
+arch=('x86_64')
+url="https://github.com/MaryHal/shmupmametgm"
+depends=('sdl' 'gconf')
+makedepends=('git')
+license=('GPL')
+source=("git+https://github.com/MaryHal/shmupmametgm.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/shmupmametgm"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make SUBTARGET=tgm NOWERROR=1 || return 1
+}
+
+package() {
+ install -Dm755 "$srcdir/$pkgname/mametgm64" -t "$pkgdir/usr/bin/"
+}
+