summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2021-11-25 05:34:49 -0500
committergraysky2021-11-25 05:34:49 -0500
commit4c05ff68853795ccc14a01d31752aedb91e5c652 (patch)
treee291d1b2dee8b0a7dcdeb226fb925f4bdfe2407e
downloadaur-4c05ff68853795ccc14a01d31752aedb91e5c652.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
-rw-r--r--readme.install15
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6fb10db8860
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = shonenjump
+ pkgdesc = A faster way to change directory and improve command line productivity
+ pkgver = 0.7.20
+ pkgrel = 1
+ url = https://github.com/suzaku/shonenjump
+ install = readme.install
+ arch = x86_64
+ license = custom
+ makedepends = go
+ depends = bash
+ conflicts = autojump
+ source = shonenjump-0.7.20.tar.gz::https://github.com/suzaku/shonenjump/archive/refs/tags/v0.7.20.tar.gz
+ b2sums = fbc85639dfde6451a7103d186e6d2db72b9d6b2294c13f794b80d50804b544b47d7422b93375026473eb732a9cd9597ad8016903d8e2370e54e9868b8c9001f7
+
+pkgname = shonenjump
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97d6da5752dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: graysky <graysky AT archlinux DOT us>
+
+pkgname=shonenjump
+pkgver=0.7.20
+pkgrel=1
+pkgdesc="A faster way to change directory and improve command line productivity"
+arch=(x86_64)
+url="https://github.com/suzaku/shonenjump"
+license=(custom)
+depends=(bash)
+makedepends=(go)
+conflicts=(autojump)
+install=readme.install
+source=("$pkgname-$pkgver.tar.gz::https://github.com/suzaku/shonenjump/archive/refs/tags/v$pkgver.tar.gz")
+b2sums=('fbc85639dfde6451a7103d186e6d2db72b9d6b2294c13f794b80d50804b544b47d7422b93375026473eb732a9cd9597ad8016903d8e2370e54e9868b8c9001f7')
+
+build() {
+ cd "$pkgname-$pkgver"
+ go build -v -buildmode=pie -ldflags "-extldflags \"$LDFLAGS\""
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -d "$pkgdir/usr/bin/"
+ install -m755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ install -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -d "$pkgdir/etc/profile.d"
+
+ cd scripts
+ for i in bash fish zsh; do
+ install -m644 "$pkgname.$i" "$pkgdir/etc/profile.d/$pkgname.$i"
+ done
+
+ install -d "$pkgdir/usr/share/zsh/site-functions"
+ install -m644 _j "$pkgdir/usr/share/zsh/site-functions/_j"
+}
diff --git a/readme.install b/readme.install
new file mode 100644
index 000000000000..10e3879fac69
--- /dev/null
+++ b/readme.install
@@ -0,0 +1,15 @@
+## arg 1: the new package version
+## arg 2: the old package version
+
+post_install() {
+ cat <<END
+>>> Bash users will need to add the following to ~/.bashrc:
+ [[ -f /etc/profile.d/shonenjump.sh ]] && source /etc/profile.d/shonenjump.sh
+
+ Fish users will need to add the following to ~/.config/fish/config.fish:
+ [ -f /usr/share/shonenjump/shonenjump.fish ]; and source /usr/share/shonenjump/shonenjump.fish
+
+ Zsh users will need to add the following to ~/.zshrc:
+ [[ -f /etc/profile.d/shonenjump.zsh ]] && source /etc/profile.d/shonenjump.zsh
+END
+}