summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJordan Klassen2015-12-16 22:55:57 -0800
committerJordan Klassen2015-12-16 22:55:57 -0800
commit99766441bc9b67607fd85c6a2c79708c4ec59dd3 (patch)
treed8f67cfcdd9bf97546248c179cdf930da8c9b9b0
downloadaur-99766441bc9b67607fd85c6a2c79708c4ec59dd3.tar.gz
v0.3.4
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD28
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7294db655e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Dec 17 06:54:02 UTC 2015
+pkgbase = shopify-themekit-bin
+ pkgdesc = A cross-platform tool for building Shopify Themes
+ pkgver = 0.3.4
+ pkgrel = 1
+ url = https://github.com/Shopify/themekit
+ arch = i686
+ arch = x86_64
+ license = MIT
+ conflicts = shopify-themekit
+ source_i686 = shopify-themekit-v0.3.4-i686.zip::https://github.com/Shopify/themekit/releases/download/0.3.4/linux-386.zip
+ md5sums_i686 = e356d2f2c35b074c0c6f36ffbfc9941a
+ source_x86_64 = shopify-themekit-v0.3.4-x86_64.zip::https://github.com/Shopify/themekit/releases/download/0.3.4/linux-amd64.zip
+ md5sums_x86_64 = 4b42406c6c75600e5477738b826a2900
+
+pkgname = shopify-themekit-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..56cccf506368
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pkg
+/src
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b603c342ef0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jordan J Klassen <forivall@gmail.com>
+# Upstream URL: https://github.com/atom/atom
+
+pkgname=shopify-themekit-bin
+pkgver=0.3.4
+pkgrel=1
+pkgdesc="A cross-platform tool for building Shopify Themes"
+arch=('i686' 'x86_64')
+
+url="https://github.com/Shopify/themekit"
+license=('MIT')
+depends=()
+conflicts=('shopify-themekit')
+
+source_i686=("shopify-themekit-v${pkgver}-i686.zip::https://github.com/Shopify/themekit/releases/download/${pkgver}/linux-386.zip")
+source_x86_64=("shopify-themekit-v${pkgver}-x86_64.zip::https://github.com/Shopify/themekit/releases/download/${pkgver}/linux-amd64.zip")
+md5sums_i686=('e356d2f2c35b074c0c6f36ffbfc9941a')
+md5sums_x86_64=('4b42406c6c75600e5477738b826a2900')
+
+package() {
+ local subdir
+ if [ "$CARCH" = "i686" ]; then
+ subdir="linux-386"
+ else
+ subdir="linux-amd64"
+ fi
+ install -Dm0755 "${srcdir}/${subdir}/theme" "${pkgdir}/usr/bin/theme"
+}