summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRob McFadzean2018-06-12 21:46:47 +0930
committerRob McFadzean2018-06-12 21:46:47 +0930
commita7e8322dca7e817dcc2c0b363ef76b11c83b67f7 (patch)
tree2d9bce2e402d99ee27f4a5ca510daa7aca09bb59
parent4aa8846ba578dc553159d143f19e4fae422800ab (diff)
downloadaur-a7e8322dca7e817dcc2c0b363ef76b11c83b67f7.tar.gz
Updated themekit to 0.7.5 - thanks @Schnouki
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD22
3 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 511bf9586e83..87c7c1678943 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = shopify-themekit-bin
pkgdesc = A cross-platform tool for building Shopify Themes
- pkgver = 0.6.11
+ pkgver = 0.7.5
pkgrel = 1
url = https://github.com/Shopify/themekit
arch = i686
arch = x86_64
license = MIT
conflicts = shopify-themekit
- source_i686 = shopify-themekit-v0.6.11-i686.zip::https://github.com/Shopify/themekit/releases/download/v0.6.11/linux-386.zip
- sha256sums_i686 = 6da2f2f33acd0b7ac6de2ed107f2bf8d82757eb28e61ccb9fe188525cf019e13
- source_x86_64 = shopify-themekit-v0.6.11-x86_64.zip::https://github.com/Shopify/themekit/releases/download/v0.6.11/linux-amd64.zip
- sha256sums_x86_64 = 49f9fc2e7a386d1cd46f77263adb1ab4553ce419b16b52381274ed59074d68b0
+ source_i686 = theme.i686::https://shopify-themekit.s3.amazonaws.com/v0.7.5/linux-386/theme
+ md5sums_i686 = c62833ae71340a73663d4a240c00e4d0
+ sha256sums_i686 = 2f2c4066b660bb8eafff6edb82a1356be4150738dc8831bf06187581f7a215da
+ source_x86_64 = theme.x86_64::https://shopify-themekit.s3.amazonaws.com/v0.7.5/linux-amd64/theme
+ md5sums_x86_64 = 9b9770e282c998f664c6d6728e5d3df6
+ sha256sums_x86_64 = c2a6e006ae0e6d7152c9cd6a6097f60c7b2bbed2897b1c48269549285992a6aa
pkgname = shopify-themekit-bin
diff --git a/.gitignore b/.gitignore
index 56cccf506368..18c3416b9e1f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,5 @@
/pkg
/src
*.zip
+*.tar.xz
+theme.x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 1a34c892af78..c76996a05136 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,25 @@
# Maintainer: Rob McFadzean <root@sphericalcube.net>
# Contributor: Jordan J Klassen <forivall@gmail.com>
+# Contributor: Thomas Jost <schnouki@schnouki.net>
# Upstream URL: https://github.com/Shopify/themekit
pkgname=shopify-themekit-bin
-pkgver=0.6.11
+pkgver=0.7.5
pkgrel=1
pkgdesc="A cross-platform tool for building Shopify Themes"
arch=('i686' 'x86_64')
url="https://github.com/Shopify/themekit"
license=('MIT')
-depends=()
conflicts=('shopify-themekit')
-source_i686=("shopify-themekit-v${pkgver}-i686.zip::https://github.com/Shopify/themekit/releases/download/v${pkgver}/linux-386.zip")
-source_x86_64=("shopify-themekit-v${pkgver}-x86_64.zip::https://github.com/Shopify/themekit/releases/download/v${pkgver}/linux-amd64.zip")
-sha256sums_i686=('6da2f2f33acd0b7ac6de2ed107f2bf8d82757eb28e61ccb9fe188525cf019e13')
-sha256sums_x86_64=('49f9fc2e7a386d1cd46f77263adb1ab4553ce419b16b52381274ed59074d68b0')
+source_i686=("theme.i686::https://shopify-themekit.s3.amazonaws.com/v${pkgver}/linux-386/theme")
+source_x86_64=("theme.x86_64::https://shopify-themekit.s3.amazonaws.com/v${pkgver}/linux-amd64/theme")
+md5sums_i686=('c62833ae71340a73663d4a240c00e4d0')
+md5sums_x86_64=('9b9770e282c998f664c6d6728e5d3df6')
+sha256sums_i686=('2f2c4066b660bb8eafff6edb82a1356be4150738dc8831bf06187581f7a215da')
+sha256sums_x86_64=('c2a6e006ae0e6d7152c9cd6a6097f60c7b2bbed2897b1c48269549285992a6aa')
package() {
- local subdir
- if [ "$CARCH" = "i686" ]; then
- subdir="linux-386"
- else
- subdir="linux-amd64"
- fi
- install -Dm0755 "${srcdir}/${subdir}/theme" "${pkgdir}/usr/bin/theme"
+ install -Dm0755 "${srcdir}/theme.${CARCH}" "${pkgdir}/usr/bin/theme"
}