summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-08 14:01:55 +0800
committerzxp198210052023-11-08 14:01:55 +0800
commitc79f14c5e996e59cca6d61836efeb03560b6f243 (patch)
tree72e68bbae42ebc9706ece70abe4eca56fb96fb7f
parente4984cf3bef1ae3661936211ad1ac377b4d538da (diff)
downloadaur-c79f14c5e996e59cca6d61836efeb03560b6f243.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD29
-rw-r--r--shoppinglist.sh5
3 files changed, 24 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1175ab7e8caa..242b16ac6593 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = shoppinglist-bin
pkgdesc = A user-friendly shopping list application developed using Electron and MaterializeCss.
pkgver = 1.0.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/MillerSpil/ShoppingListApplication
arch = x86_64
license = MIT
- makedepends = asar
makedepends = gendesk
depends = bash
depends = electron17
@@ -14,6 +13,6 @@ pkgbase = shoppinglist-bin
source = shoppinglist-1.0.0.7z::https://github.com/MillerSpil/ShoppingListApplication/releases/download/production-linux/shoppinglist-linux-x64.7z
source = shoppinglist.sh
sha256sums = e109b2e649081083a3c0374f1d26bc00242892bf5fc5478158dfed29521610d1
- sha256sums = d82a6f76dfef0f7c9967477f553427eb79414bf127123227a88f25abd23b403f
+ sha256sums = d828933795970cb125bb9f5d8e972ad485d1415e2a89a1417176661ada4d8925
pkgname = shoppinglist-bin
diff --git a/PKGBUILD b/PKGBUILD
index 85980fe8ab0e..7200ec8b3b6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,34 @@
pkgname=shoppinglist-bin
_pkgname=ShoppingList
pkgver=1.0.0
-pkgrel=3
+pkgrel=4
pkgdesc="A user-friendly shopping list application developed using Electron and MaterializeCss."
arch=("x86_64")
url="https://github.com/MillerSpil/ShoppingListApplication"
license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('bash' 'electron17')
-makedepends=('asar' 'gendesk')
-source=("${pkgname%-bin}-${pkgver}.7z::${url}/releases/download/production-linux/${pkgname%-bin}-linux-x64.7z"
- "${pkgname%-bin}.sh")
+depends=(
+ 'bash'
+ 'electron17'
+)
+makedepends=(
+ 'gendesk'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.7z::${url}/releases/download/production-linux/${pkgname%-bin}-linux-x64.7z"
+ "${pkgname%-bin}.sh"
+)
sha256sums=('e109b2e649081083a3c0374f1d26bc00242892bf5fc5478158dfed29521610d1'
- 'd82a6f76dfef0f7c9967477f553427eb79414bf127123227a88f25abd23b403f')
-prepare() {
- asar pack "${srcdir}/${pkgname%-bin}-linux-x64/resources/app" "${srcdir}/${pkgname%-bin}.asar"
- gendesk -f -n --categories "Utility" --name "${_pkgname}" --exec "${pkgname%-bin}"
+ 'd828933795970cb125bb9f5d8e972ad485d1415e2a89a1417176661ada4d8925')
+build() {
+ gendesk -f -n -q --categories "Utility" --name "${_pkgname}" --exec "${pkgname%-bin}"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
- install -Dm644 "${srcdir}/${pkgname%-bin}.asar" -t "${pkgdir}/opt/${pkgname%-bin}"
- install -Dm644 "${srcdir}/${pkgname%-bin}-linux-x64/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}-linux-x64/swiftshader/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/swiftshader"
+ cp -r "${srcdir}/${pkgname%-bin}-linux-x64/resources/app" "${pkgdir}/usr/lib/${pkgname%-bin}"
install -Dm644 "${srcdir}/${pkgname%-bin}-linux-x64/resources/app/assets/icons/png/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/${pkgname%-bin}-linux-x64/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file
diff --git a/shoppinglist.sh b/shoppinglist.sh
index ef0bee2ffa6c..742e709ad42d 100644
--- a/shoppinglist.sh
+++ b/shoppinglist.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron17
-_ASAR="/opt/shoppinglist/shoppinglist.asar"
+APPDIR="/usr/lib/shoppinglist"
+export PATH="${APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else