summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Perry (Pezz)2016-08-30 13:40:53 +1000
committerSimon Perry (Pezz)2016-08-30 13:40:53 +1000
commita3ee3753f7b1c51857fea85ac0058827108f0184 (patch)
tree695de72b45d4de6ee73d22fc0395a7abf5faf4e1
downloadaur-a3ee3753f7b1c51857fea85ac0058827108f0184.tar.gz
Initial commit: 0.3.1-1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
-rw-r--r--shortcircuit-start.sh4
-rw-r--r--shortcircuit.desktop10
-rwxr-xr-xupdate.sh12
5 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ffb9dce16212
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Aug 30 03:37:27 UTC 2016
+pkgbase = shortcircuit
+ pkgdesc = A tool for EVE Online that finds the shortest path between solar systems (including wormholes)
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/farshield/shortcircuit
+ arch = any
+ license = MIT
+ depends = python2
+ depends = python2-requests
+ depends = python2-pyside
+ source = https://github.com/farshield/shortcircuit/archive/v.0.1.3-beta.tar.gz
+ source = shortcircuit.desktop
+ source = shortcircuit-start.sh
+ sha256sums = aa80dcd1ddd20ad3af38e6fd59c3f69b2a531a5625fcd0ca5663d3b57d29c401
+ sha256sums = c842df29562e69f47f2cab65e05b3d7127b8b6aa835c6f1a0ebc884b6e15fa68
+ sha256sums = bccc903ac6e467fc52b88aa6260fd3d0ea26420bb26c79f1fd4ce21338f9793b
+
+pkgname = shortcircuit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be3f4382f87b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Simon Perry (Pezz) <aur@sanxion.net>
+
+pkgname=shortcircuit
+pkgver=0.1.3
+pkgrel=1
+_reltype='beta'
+pkgdesc='A tool for EVE Online that finds the shortest path between solar systems (including wormholes)'
+arch=('any')
+url='https://github.com/farshield/shortcircuit'
+license=('MIT')
+depends=('python2' 'python2-requests' 'python2-pyside')
+source=("https://github.com/farshield/$pkgname/archive/v.$pkgver-$_reltype.tar.gz"
+ ${pkgname}.desktop
+ ${pkgname}-start.sh)
+
+package() {
+ cd "${srcdir}/${pkgname}-v.${pkgver}-${_reltype}"
+
+ install -d ${pkgdir}/usr/bin
+ install -d ${pkgdir}/usr/share/{applications,pixmaps,${pkgname}}
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+
+ cp -R {resources,src} ${pkgdir}/usr/share/${pkgname}
+ install -m 644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}
+ install -m 644 README.md ${pkgdir}/usr/share/${pkgname}
+ install -m 644 resources/images/app_icon.png ${pkgdir}/usr/share/pixmaps/${pkgname}.png
+ install -m 644 ${srcdir}/${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+ install -m 755 ${srcdir}/${pkgname}-start.sh ${pkgdir}/usr/bin/${pkgname}
+}
+
+sha256sums=('aa80dcd1ddd20ad3af38e6fd59c3f69b2a531a5625fcd0ca5663d3b57d29c401'
+ 'c842df29562e69f47f2cab65e05b3d7127b8b6aa835c6f1a0ebc884b6e15fa68'
+ 'bccc903ac6e467fc52b88aa6260fd3d0ea26420bb26c79f1fd4ce21338f9793b')
diff --git a/shortcircuit-start.sh b/shortcircuit-start.sh
new file mode 100644
index 000000000000..84f559edd079
--- /dev/null
+++ b/shortcircuit-start.sh
@@ -0,0 +1,4 @@
+#!/usr/bin/sh
+
+python2 /usr/share/shortcircuit/src/main.py
+
diff --git a/shortcircuit.desktop b/shortcircuit.desktop
new file mode 100644
index 000000000000..e19e64217ef7
--- /dev/null
+++ b/shortcircuit.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=0.1.3
+Encoding=UTF-8
+Name=Short Circuit
+Comment=Short Circuit for EVE Online
+Exec=/usr/bin/shortcircuit
+Terminal=false
+Icon=shortcircuit
+Type=Application
+Categories=Application;Game;
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..c3e6d5d28d59
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,12 @@
+#!/bin/bash
+
+source PKGBUILD
+sed -i "s/^Version=.*$/Version=${pkgver}/" shortcircuit.desktop
+sed -i "/^sha256sums=(/,/)/d" PKGBUILD
+makepkg -g >> PKGBUILD
+mksrcinfo
+rm -f *.tar.gz
+
+git add --all
+git commit -m "Bump to: $pkgver-$pkgrel"
+git push