summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoost Bremmer2022-08-06 16:41:29 +0200
committerJoost Bremmer2022-08-06 16:41:29 +0200
commit8ca5b480744dd54ce311b6f952d755a85286f11d (patch)
tree88096cc332d7edc7064e0d0898b7f8a333a38ec6
parentec709fee009f24d33d4792d2f47f684661e20222 (diff)
downloadaur-8ca5b480744dd54ce311b6f952d755a85286f11d.tar.gz
Update package to version 0.2.0
-rw-r--r--PKGBUILD10
-rw-r--r--shortcut-c-client.patch21
2 files changed, 15 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e296946a560..e39d135a5bd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer Joost Bremmer <contact@madeofmagicandowires.online>
pkgbase=shortcut-git
pkgname=('shortcut-pages-git' 'shortcut-pages-extra-git' 'shortcut-c-client-git')
-pkgver=0.1.0
+pkgver=0.2.0
pkgrel=1
pkgdesc="A commandline client to list shortcuts"
url="https://github.com/mt-empty/shortcut-c-client"
@@ -13,18 +13,16 @@ source=("shortcut-pages::git+https://github.com/mt-empty/shortcut-pages.git"
"shortcut-c-client.patch")
sha256sums=('SKIP'
'SKIP'
- '61511fb1b61e7d07e3819d6bae477537ab14d4acd27490ddab5fa1a121822464')
+ 'f9b9c032afda9f3312bc4cc3edd6890bc7ad0d76174aaaeac1af03a0f134bfc2')
pkgver() {
cd "${srcdir}/shortcut-pages"
- git describe --long --tags 2>/dev/null | sed 's/[^[:digit:]]*\(.\+\)-\([[:digit:]]\+\)-g\([[:xdigit:]]\{7\}\)/\1.r\2.g\3/;t;q1'
- [ ${PIPESTATUS[0]} -eq 0 ] || \
- printf "0.1.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "0.2.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd "${srcdir}/shortcut-c-client"
- patch -Np1 --input "${srcdir}/shortcut-c-client.patch"
+ # patch -Np1 --input "${srcdir}/shortcut-c-client.patch"
}
diff --git a/shortcut-c-client.patch b/shortcut-c-client.patch
index f47bbe6f1cee..fde26211f147 100644
--- a/shortcut-c-client.patch
+++ b/shortcut-c-client.patch
@@ -1,15 +1,16 @@
Only in old: .git
+Only in old: .github
Only in old: .gitignore
Only in new: old
diff -aur old/shortcut.c new/shortcut.c
---- old/shortcut.c 2020-04-04 23:59:27.301091762 +0200
-+++ new/shortcut.c 2020-04-05 00:01:08.758271659 +0200
-@@ -28,7 +28,7 @@
-
- #define VERSION "0.1.0"
+--- old/shortcut.c 2022-08-06 16:11:39.356002537 +0200
++++ new/shortcut.c 2022-08-06 16:14:07.570579912 +0200
+@@ -35,7 +35,7 @@
#define BUFFER_SIZE 1000
--#define PAGES_BASE_DIR "/opt/shortcut/pages/"
-+#define PAGES_BASE_DIR "/usr/share/shortcut/pages/"
- #define PAGES_FILE_EXT ".md"
-
- #define ANSI_COLOR_RESET_FG "\x1b[39m"
+
+ #ifndef PAGES_DIR
+- #define PAGES_BASE_DIR "/opt/shortcut/pages/"
++ #define PAGES_BASE_DIR "/usr/share/shortcut/pages/"
+ #else
+ #define PAGES_BASE_DIR PAGES_DIR
+ #endif