summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThat One Seong2023-12-02 00:30:09 -0500
committerThat One Seong2023-12-02 00:30:09 -0500
commit82b1a775262cc73ae2edb9b14019ca93a3c6992c (patch)
tree360dd82a958a5357a9bac8f5e7acda4384573a03
downloadaur-82b1a775262cc73ae2edb9b14019ca93a3c6992c.tar.gz
Initial commit.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
-rw-r--r--shortix-desktop.install6
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..521937dfd011
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = shortix-desktop
+ pkgdesc = Script that creates human-readable symlinks for Steam Proton game prefixes, adapted for traditional desktops.
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = https://github.com/Jannomag/shortix
+ install = shortix-desktop.install
+ arch = any
+ license = GPL3
+ depends = sed
+ optdepends = steam: create and run proton prefixes
+ source = https://github.com/SeongGino/shortix/archive/refs/tags/v0.6.1.zip
+ sha256sums = 0c0ac91a066ac20afa19863b57a42c7528b19e078bfb850b2b73ff320eb7d8cf
+
+pkgname = shortix-desktop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..338bb5ca400d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: That One Seong <ThatOneSeong@protonmail.com>
+
+pkgname=shortix-desktop
+_name=shortix
+pkgver=0.6.1
+pkgrel=1
+pkgdesc='Script that creates human-readable symlinks for Steam Proton game prefixes, adapted for traditional desktops.'
+arch=('any')
+url='https://github.com/Jannomag/shortix'
+license=('GPL3')
+depends=('sed')
+optdepends=('steam: create and run proton prefixes')
+install=$pkgname.install
+source=("https://github.com/SeongGino/shortix/archive/refs/tags/v$pkgver.zip")
+sha256sums=('0c0ac91a066ac20afa19863b57a42c7528b19e078bfb850b2b73ff320eb7d8cf')
+
+package() {
+ cd "$_name-$pkgver"
+ install -Dp shortix.sh "$pkgdir/usr/bin/shortix"
+ install -Dp remove_prefix.sh "$pkgdir/usr/bin/shortix-delete"
+ install -Dp shortix.service "$pkgdir/usr/lib/systemd/user/shortix.service"
+}
diff --git a/shortix-desktop.install b/shortix-desktop.install
new file mode 100644
index 000000000000..b843ed867afa
--- /dev/null
+++ b/shortix-desktop.install
@@ -0,0 +1,6 @@
+post_install() {
+ cat <<- EOF
+ :: Enable/start with
+ :: systemctl --user enable --now shortix.service
+ EOF
+}