summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2020-09-03 20:06:16 +0200
committerValHue2020-09-03 20:06:16 +0200
commit202be13272df8447540ce8a9be7206875a9eb985 (patch)
tree9fa2cabc88aba742512405af92783de3828eb4bd
parentd10ba50274e8fc0165343c50f996677261d637d3 (diff)
downloadaur-202be13272df8447540ce8a9be7206875a9eb985.tar.gz
Remove the reference to the branch
-rw-r--r--PKGBUILD17
-rw-r--r--handy.patch43
2 files changed, 53 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 41e7c8272899..873f0d61ad74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,22 +5,25 @@
_pkgname="Shortwave"
pkgname="shortwave"
pkgver="1.1.1"
-pkgrel="4"
+pkgrel="5"
epoch="1"
pkgdesc="Find and listen to internet radio stations."
arch=('any')
url="https://gitlab.gnome.org/World/${_pkgname}"
license=('GPL3')
depends=('gst-plugins-bad' 'libhandy' 'libsoup' 'gtk3')
-makedepends=('cargo' 'git' 'gobject-introspection' 'gst-plugins-base-libs' 'libdazzle' 'meson' 'rustup')
+makedepends=('cargo' 'git' 'gobject-introspection' 'gst-plugins-base-libs' 'libdazzle' 'meson' 'rust')
options=('!emptydirs')
-source=("${_pkgname}-${pkgver}.tar.gz::${url}/-/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('b391b4d10658e9ba180442ca2d769173a278f19beb498c7251a6b4a62b7c678b')
+source=("${_pkgname}-${pkgver}.tar.gz::${url}/-/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz"
+ "handy.patch"
+)
+sha256sums=('b391b4d10658e9ba180442ca2d769173a278f19beb498c7251a6b4a62b7c678b'
+ '01bbac29d6aacf6bedbfc49632db24f05c7df9e52aecd2143a42e41df9f097d9'
+)
prepare() {
- rustup install 1.45.2
- rustup default 1.45.2
- echo "Rust version used during this build: `rustc \-V`"
+ cd "${_pkgname}-${pkgver}"
+ patch -Np1 -i ../handy.patch
}
build() {
diff --git a/handy.patch b/handy.patch
new file mode 100644
index 000000000000..2157a6dcb168
--- /dev/null
+++ b/handy.patch
@@ -0,0 +1,43 @@
+diff --git a/Cargo.lock b/Cargo.lock
+index 562ee21..39f6725 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -917,7 +917,7 @@ dependencies = [
+ [[package]]
+ name = "libhandy"
+ version = "0.5.0"
+-source = "git+https://gitlab.gnome.org/haecker-felix/libhandy-rs.git?branch=update_cargo_version#62e7abf44d419cf3fe83da64285f2905da4e333e"
++source = "git+https://gitlab.gnome.org/haecker-felix/libhandy-rs.git#62e7abf44d419cf3fe83da64285f2905da4e333e"
+ dependencies = [
+ "bitflags 1.2.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "gdk 0.12.0 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -931,14 +931,14 @@ dependencies = [
+ "gtk-sys 0.9.2 (registry+https://github.com/rust-lang/crates.io-index)",
+ "lazy_static 1.4.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "libc 0.2.66 (registry+https://github.com/rust-lang/crates.io-index)",
+- "libhandy-sys 0.5.0 (git+https://gitlab.gnome.org/haecker-felix/libhandy-rs.git?branch=update_cargo_version)",
++ "libhandy-sys 0.5.0 (git+https://gitlab.gnome.org/haecker-felix/libhandy-rs.git)",
+ "pango 0.8.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+
+ [[package]]
+ name = "libhandy-sys"
+ version = "0.5.0"
+-source = "git+https://gitlab.gnome.org/haecker-felix/libhandy-rs.git?branch=update_cargo_version#62e7abf44d419cf3fe83da64285f2905da4e333e"
++source = "git+https://gitlab.gnome.org/haecker-felix/libhandy-rs.git#62e7abf44d419cf3fe83da64285f2905da4e333e"
+ dependencies = [
+ "gdk 0.12.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "gdk-sys 0.9.1 (registry+https://github.com/rust-lang/crates.io-index)",
+diff --git a/Cargo.toml b/Cargo.toml
+index d55d84a..b08e12f 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -42,7 +42,7 @@ gtk = { version = "0.8.0", features = ["v3_22"] }
+ gio = { version = "0.8.0", features = ["v2_46"] }
+ gdk-pixbuf = { version = "0.8.0", features = ["v2_36"] }
+ gettext-rs = { version = "0.4.4", features = ["gettext-system"] }
+-libhandy = { git="https://gitlab.gnome.org/haecker-felix/libhandy-rs.git", branch = "update_cargo_version", features = ["v0_0_12"] }
++libhandy = { git="https://gitlab.gnome.org/haecker-felix/libhandy-rs.git", features = ["v0_0_12"] }
+ gtk-macros = "0.2.0"
+
+ [target.'cfg(unix)'.dependencies]