summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrr-2016-03-17 19:51:04 +0100
committerrr-2016-03-17 19:51:04 +0100
commit3469c8291f8672e305dc2209695a305dc6fb54fa (patch)
tree6348fd344b6821dfe35b462105bd263536aa17b2
parent01df6496e3059914123b445c16f6afc552ba5ffa (diff)
downloadaur-3469c8291f8672e305dc2209695a305dc6fb54fa.tar.gz
Update to cmake
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e25bd233200d..457e54741dd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,13 +18,14 @@ pkgver() {
build() {
cd "$pkgname"
- ./bootstrap
- ./waf configure
- ./waf
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_RELEASE_TYPE=Release
+ make
}
package() {
cd "$pkgname"
- install -Dm755 build/shot "$pkgdir/usr/bin/shot"
- install -Dm644 docs/shot.1 "$pkgdir/usr/share/man/man1/shot.1p"
+ cd build
+ make DESTDIR="$pkgdir" install
}