summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2024-02-21 09:16:01 +0100
committerAlphaJack2024-02-21 09:16:01 +0100
commitff26074dfa8f25ffa433e1e1f54380e8e151ff27 (patch)
tree1a67526719f99780c1b19a442d55481b359d3438
downloadaur-ff26074dfa8f25ffa433e1e1f54380e8e151ff27.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..111ca36f8cc8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = shot-scraper
+ pkgdesc = A command-line utility for taking automated screenshots of websites
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://shot-scraper.datasette.io/
+ arch = any
+ license = Apache-2.0
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
+ depends = playwright
+ depends = python
+ depends = python-playwright
+ options = !strip
+ source = https://files.pythonhosted.org/packages/source/s/shot-scraper/shot-scraper-1.4.tar.gz
+ b2sums = b6d8378968e147b88d740a35afd5fb222660e2aa44d498304bbd589a23c749fbb30fc010e47d654d1bdfe16ffeca68f8b01e4e4becadc9c1c3e392f5ce96dee1
+
+pkgname = shot-scraper
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f4d9eb93c8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="shot-scraper"
+pkgver=1.4
+pkgrel=1
+pkgdesc="A command-line utility for taking automated screenshots of websites"
+url="https://shot-scraper.datasette.io/"
+license=("Apache-2.0")
+arch=("any")
+depends=("playwright"
+ "python"
+ "python-playwright")
+makedepends=("python-build"
+ "python-installer"
+ "python-wheel"
+ "python-setuptools")
+options=("!strip")
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+b2sums=('b6d8378968e147b88d740a35afd5fb222660e2aa44d498304bbd589a23c749fbb30fc010e47d654d1bdfe16ffeca68f8b01e4e4becadc9c1c3e392f5ce96dee1')
+
+build(){
+ cd "$pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package(){
+ cd "$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}