summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2023-02-10 16:25:12 +0100
committerHugo Osvaldo Barrera2023-02-10 16:25:40 +0100
commit0837f26fe72e0f6adf6725fd94d9388b45ea7663 (patch)
treede5bad7d49623efe001551ecf9484b12a9328e7b
parentd87c00d74e84fc72ea90f28863e571b31813d7b0 (diff)
downloadaur-0837f26fe72e0f6adf6725fd94d9388b45ea7663.tar.gz
Update to 0.4.1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21bfb7cf173d..61650da5519c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = shotman
pkgdesc = Uncompromising screenshot GUI for Wayland
- pkgver = 0.2.0
- pkgrel = 3
+ pkgver = 0.4.1
+ pkgrel = 1
url = https://git.sr.ht/~whynothugo/shotman
arch = x86_64
arch = aarch64
license = ISC
makedepends = git
makedepends = cargo
+ makedepends = scdoc
depends = libxkbcommon
optdepends = sway: screenshots of a single window on swaywm
optdepends = slurp: screenshots of a region on swaywm
diff --git a/PKGBUILD b/PKGBUILD
index c587ac578d5f..7c2b31ab2dbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
pkgname=shotman
-pkgver=0.2.0
-pkgrel=3
+pkgver=0.4.1
+pkgrel=1
pkgdesc="Uncompromising screenshot GUI for Wayland"
arch=("x86_64" "aarch64")
url="https://git.sr.ht/~whynothugo/shotman"
@@ -12,7 +12,7 @@ optdepends=(
"sway: screenshots of a single window on swaywm"
"slurp: screenshots of a region on swaywm"
)
-makedepends=("git" "cargo")
+makedepends=("git" "cargo" "scdoc")
source=("shotman-${pkgver}::git+https://git.sr.ht/~whynothugo/shotman#tag=v${pkgver}?signed")
sha512sums=("SKIP")
validpgpkeys=("1204CA9FC2FFADEEDC2961367880733B9D062837")
@@ -29,6 +29,10 @@ build() {
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
cargo build --frozen --release
+ scdoc < shotman.1.scd > shotman.1
+ ./target/release/shotman_completions bash > $pkgname.bash
+ ./target/release/shotman_completions fish > $pkgname.fish
+ ./target/release/shotman_completions zsh > $pkgname.zsh
}
check() {
@@ -42,4 +46,12 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/$pkgname"
+ install -Dm644 shotman.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
+
+ install -Dm644 $pkgname.bash \
+ "$pkgdir"/usr/share/bash-completion/completions/$pkgname
+ install -Dm644 $pkgname.fish \
+ "$pkgdir"/usr/share/fish/completions/$pkgname.fish
+ install -Dm644 $pkgname.zsh \
+ "$pkgdir"/usr/share/zsh/site-functions/_$pkgname
}