summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAyush2017-12-10 22:44:16 +0530
committerAyush2017-12-10 22:44:16 +0530
commit2da781f9a9ae60db39c826929241fbd5fafcf3d9 (patch)
tree7719381053a9edf1f840119310ef8243ee95192a
downloadaur-2da781f9a9ae60db39c826929241fbd5fafcf3d9.tar.gz
init
-rwxr-xr-x.SRCINFO26
-rwxr-xr-xPKGBUILD33
-rw-r--r--shotpy.desktop9
-rwxr-xr-xshotpy.install14
-rwxr-xr-xshotpy.pngbin0 -> 581 bytes
5 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100755
index 000000000000..6f9a387c18d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = shotpy
+ pkgdesc = Python script to upload pictures or screenshots to Imgur.
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/AyushBhat/shotpy
+ install = shotpy.install
+ arch = any
+ license = GPL
+ depends = curl
+ depends = grep
+ depends = scrot
+ depends = python>=3.6
+ depends = libnotify
+ depends = xclip
+ optdepends = libnotify: for desktop notifications
+ optdepends = scrot: for making screenshots
+ optdepends = xclip: for copying screenshot URLs to clipboard
+ source = git+https://github.com/AyushBhat/shotpy.git
+ source = shotpy.desktop
+ source = shotpy.png
+ md5sums = SKIP
+ md5sums = 459431a977061e56894315ce151d9bef
+ md5sums = 3780c9f2183f7d4705ab86ab077e3885
+
+pkgname = shotpy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..183fbbf68dcc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: ValdikSS <tfeayush@gmail.com>
+
+pkgname=shotpy
+pkgver=0.1
+pkgrel=1
+pkgdesc="Python script to upload pictures or screenshots to Imgur."
+arch=('any')
+url="https://github.com/AyushBhat/shotpy"
+license=('GPL')
+depends=('curl' 'grep' 'scrot' 'python>=3.6' 'libnotify' 'xclip')
+optdepends=('libnotify: for desktop notifications'
+ 'scrot: for making screenshots'
+ 'xclip: for copying screenshot URLs to clipboard')
+install='shotpy.install'
+source=('git+https://github.com/AyushBhat/shotpy.git'
+ 'shotpy.desktop'
+ 'shotpy.png')
+md5sums=('SKIP'
+ '459431a977061e56894315ce151d9bef'
+ '3780c9f2183f7d4705ab86ab077e3885')
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ sed -i 's~$HOME/Pictures/imgur.png~/usr/share/pixmaps/shotpy.png~' shotpy.py
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm644 "$srcdir/shotpy.png" "$pkgdir/usr/share/pixmaps/shotpy.png"
+ install -Dm644 "$srcdir/shotpy.desktop" "$pkgdir/usr/share/applications/shotpy.desktop"
+ install -Dm755 shotpy.py "$pkgdir/usr/bin/shotpy"
+}
diff --git a/shotpy.desktop b/shotpy.desktop
new file mode 100644
index 000000000000..b81add91858a
--- /dev/null
+++ b/shotpy.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=imgur-screenshot
+Comment=Upload the image to imgur web service
+Exec=imgur-screenshot %F
+Icon=/usr/share/pixmaps/imgur-screenshot.png
+MimeType=image/png;image/jpeg;image/bmp;image/gif;image/tiff;image/xcf;
+Categories=Graphics;Network;
diff --git a/shotpy.install b/shotpy.install
new file mode 100755
index 000000000000..d22b1c8c37ff
--- /dev/null
+++ b/shotpy.install
@@ -0,0 +1,14 @@
+post_install() {
+ update-desktop-database -q
+ echo "Visit https://github.com/AyushBhat/shotpy for configuration help"
+}
+
+post_upgrade() {
+ update-desktop-database -q
+}
+
+post_remove() {
+ post_upgrade
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/shotpy.png b/shotpy.png
new file mode 100755
index 000000000000..4eec172012ac
--- /dev/null
+++ b/shotpy.png
Binary files differ