summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbanbanchs2015-11-16 21:04:52 +0800
committerbanbanchs2015-11-16 21:04:52 +0800
commitac4fde50e0ea1f98198cebccb8f1e7861dff0529 (patch)
tree307e0243de08b27f43e8e9fcb5752f563d3d8841
downloadaur-ac4fde50e0ea1f98198cebccb8f1e7861dff0529.tar.gz
Add showimage 1.9
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17d3d35ea6a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = showimage
+ pkgdesc = ShowImage is a simple KDE based image viewer using the maximum space inside its window without cluttering the window with menubar, toolbar or statusbar.
+ pkgver = 1.9.1
+ pkgrel = 1
+ url = http://opendesktop.org/content/show.php/ShowImage?content=143977
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = automoc4
+ depends = kdelibs
+ source = http://opendesktop.org/CONTENT/content-files/143977-showimage-1.9.tar.bz2
+ sha256sums = be21dd3d46be4347601187a7533449d72bc13b75c5346355b274c33a0b9eea61
+
+pkgname = showimage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4598104978f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: banbanchs <memory.silentvoyage[at]gmail.com>
+# Contributor: Alexander Kazarin <boiler[at]co.ru>
+pkgname=showimage
+pkgver=1.9.1
+_pkgver=1.9
+pkgrel=1
+pkgdesc="ShowImage is a simple KDE based image viewer using the maximum space inside its window without cluttering the window with menubar, toolbar or statusbar."
+_odid=143977
+url="http://opendesktop.org/content/show.php/ShowImage?content=${_odid}"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('kdelibs')
+makedepends=('cmake' 'automoc4')
+optdepends=()
+source=(http://opendesktop.org/CONTENT/content-files/${_odid}-${pkgname}-${_pkgver}.tar.bz2)
+sha256sums=('be21dd3d46be4347601187a7533449d72bc13b75c5346355b274c33a0b9eea61')
+
+build() {
+ cd ${srcdir}/${pkgname}-${_pkgver}
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${_pkgver}
+ make DESTDIR=${pkgdir} install || return 1
+}