summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2023-11-15 19:11:20 +0100
committerAlbert Graef2023-11-15 19:11:20 +0100
commit2d9b632413e0cb42cf73b498843e332e4de25e9d (patch)
tree6116fb546dcaf93f94bb7d0a2f0026eab8e8bbed
downloadaur-2d9b632413e0cb42cf73b498843e332e4de25e9d.tar.gz
Initial upload.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD66
-rw-r--r--showmidi.desktop9
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d984f7f9f737
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = showmidi-git
+ pkgdesc = Multi-platform GUI application to effortlessly visualize MIDI activity
+ pkgver = 0.6.0.r7.gbfbb72e
+ pkgrel = 1
+ url = https://github.com/gbevin/ShowMIDI
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ makedepends = pkg-config
+ makedepends = cmake
+ depends = alsa-lib
+ depends = freetype2
+ depends = libxrandr
+ depends = libxinerama
+ depends = libxcursor
+ source = ShowMIDI::git+https://github.com/gbevin/ShowMIDI.git
+ md5sums = SKIP
+
+pkgname = showmidi-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1254a8c01448
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Albert Graef <aggraef at gmail dot com>
+
+pkgname=showmidi-git
+_pkgname=ShowMIDI
+pkgver=0.6.0.r7.gbfbb72e
+pkgrel=1
+pkgdesc="Multi-platform GUI application to effortlessly visualize MIDI activity"
+arch=("i686" "x86_64")
+license=('GPLv3')
+url="https://github.com/gbevin/ShowMIDI"
+depends=('alsa-lib' 'freetype2' 'libxrandr' 'libxinerama' 'libxcursor')
+makedepends=('pkg-config' 'cmake')
+source=("$_pkgname::git+https://github.com/gbevin/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ git submodule update --init --recursive
+}
+
+build() {
+ export PATH_TO_JUCE=$srcdir/$_pkgname/JUCE
+ cd $srcdir/$_pkgname/Builds/LinuxMakefile
+ # Default on Linux is to build the VST2, VST3, and LV2 plugins. The
+ # following flag disables building the VST2 plugin to avoid license
+ # issues. If you have the VST2 SDK sources installed then you might want
+ # to remove this and check the ShowMIDI build instructions.
+ make CONFIG=Release JUCE_CPPFLAGS_VST="-DJucePlugin_Build_VST=0"
+ # Build the CLAP module. This needs cmake.
+ cd $srcdir/$_pkgname
+ cmake -BBuilds/LinuxMakefile/build/clap -DCMAKE_BUILD_TYPE=Release
+ cd $srcdir/$_pkgname/Builds/LinuxMakefile
+ cmake --build build/clap --config Release
+}
+
+package() {
+ # There's no install target, so we just install the standalone and the
+ # plugins in the usual places. We also add an icon and desktop file in the
+ # standard locations. Factory themes are installed under
+ # /usr/share/ShowMIDI/Themes, so that's where you should go looking if you
+ # want to load a theme in the setup dialog.
+
+ # Desktop entry & pixmaps
+ install -Dm644 "$srcdir/../showmidi.desktop" "${pkgdir}/usr/share/applications/showmidi.desktop"
+ install -Dm644 "$srcdir/$_pkgname/Assets/appicon.png" "${pkgdir}/usr/share/pixmaps/showmidi.png"
+
+ # Themes
+ mkdir -p "${pkgdir}/usr/share/ShowMIDI"
+ cp -r "$srcdir/$_pkgname/Themes" "${pkgdir}/usr/share/ShowMIDI"
+
+ # Standalone
+ install -Dm755 -T "$srcdir/$_pkgname/Builds/LinuxMakefile/build/ShowMIDI" "${pkgdir}/usr/bin/ShowMIDI"
+
+ # Plugins
+ mkdir -p "${pkgdir}/usr/lib/lv2"
+ cp -r "$srcdir/$_pkgname/Builds/LinuxMakefile/build/ShowMIDI.lv2" "${pkgdir}/usr/lib/lv2"
+ mkdir -p "${pkgdir}/usr/lib/vst3"
+ cp -r "$srcdir/$_pkgname/Builds/LinuxMakefile/build/ShowMIDI.vst3" "${pkgdir}/usr/lib/vst3"
+ mkdir -p "${pkgdir}/usr/lib/clap"
+ cp "$srcdir/$_pkgname/Builds/LinuxMakefile/build/clap/ShowMIDI_artefacts/Release/ShowMIDI.clap" "${pkgdir}/usr/lib/clap"
+}
diff --git a/showmidi.desktop b/showmidi.desktop
new file mode 100644
index 000000000000..ca82be633085
--- /dev/null
+++ b/showmidi.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=ShowMIDI
+Comment=Multi-platform GUI application to effortlessly visualize MIDI activity
+Exec=/usr/bin/ShowMIDI
+Icon=showmidi
+Terminal=false
+StartupNotify=false
+Categories=AudioVideo;Audio;Midi;Music;