summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-12-11 00:04:15 +0100
committerFabioLolix2018-12-11 00:04:15 +0100
commit58710148e819076128b7432b9d24e4ad53c3dc9b (patch)
tree59e7838913160b804db727cf6e56c3a724223a49
parentde2eb3d15a50320e17178ccfad83b92516070929 (diff)
downloadaur-58710148e819076128b7432b9d24e4ad53c3dc9b.tar.gz
Update deps
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad5556f59201..38c2d4a5c7f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = showmypictures-git
pkgdesc = Memories is an photo manager for Pantheon, developed by Artem Anufrij
- pkgver = 0.2.8.r0.gf2e405d
+ pkgver = 0.3.0.r7.gab53fbd
pkgrel = 1
url = http://anufrij.org/memories
arch = x86_64
@@ -13,9 +13,10 @@ pkgbase = showmypictures-git
depends = gtk3
depends = libgexiv2
depends = sqlite
+ depends = libraw
provides = showmypictures
conflicts = showmypictures
- source = showmypictures-git::git+https://github.com/artemanufrij/showmypictures.git
+ source = git+https://github.com/artemanufrij/showmypictures.git
sha256sums = SKIP
pkgname = showmypictures-git
diff --git a/PKGBUILD b/PKGBUILD
index b8c2d506bc52..272a277b9273 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,31 @@
# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
pkgname=showmypictures-git
-pkgver=0.2.8.r0.gf2e405d
+pkgver=0.3.0.r7.gab53fbd
pkgrel=1
pkgdesc="Memories is an photo manager for Pantheon, developed by Artem Anufrij"
-arch=('x86_64')
+arch=(x86_64)
url="http://anufrij.org/memories"
-license=('GPL3')
-depends=('libgranite.so' 'gtk3' 'libgexiv2' 'sqlite')
-makedepends=('vala' 'cmake' 'cmake-modules-elementary-git' 'git')
+license=(GPL3)
+depends=(libgranite.so gtk3 libgexiv2 sqlite libraw)
+makedepends=(vala cmake cmake-modules-elementary-git git)
provides=(showmypictures)
conflicts=(showmypictures)
-source=("${pkgname}::git+https://github.com/artemanufrij/showmypictures.git")
+source=("git+https://github.com/artemanufrij/showmypictures.git")
sha256sums=('SKIP')
pkgver() {
- cd "${pkgname}"
+ cd "${pkgname/-git/}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${pkgname}"
+ cd "${pkgname/-git/}"
install -d build
}
build() {
- cd "${pkgname}/build"
+ cd "${pkgname/-git/}/build"
cmake .. \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
@@ -33,6 +33,6 @@ build() {
}
package() {
- cd "${pkgname}/build"
+ cd "${pkgname/-git/}/build"
make DESTDIR="${pkgdir}" install
}