summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Bidar2015-06-13 18:47:13 +0200
committerBjörn Bidar2015-06-13 18:47:13 +0200
commit7cd83e10e4f96b7b7a455dd83fe2c6c8b4a80fd3 (patch)
treeb1cc33de56afd767e6379ebc9e06c7d10cfe442c
downloadaur-7cd83e10e4f96b7b7a455dd83fe2c6c8b4a80fd3.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..baf0316f6798
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = shpp-git
+ pkgdesc = preprocessor written for posix shell
+ pkgver = 33439b2
+ pkgrel = 1
+ url = https://github.com/Thaodan/shpp
+ arch = any
+ license = GPL2
+ depends = sh
+ depends = coreutils
+ depends = sed
+ depends = bc
+ provides = shpp
+ conflicts = sh-make-tools
+ source = git+https://github.com/Thaodan/shpp
+ md5sums = SKIP
+
+pkgname = shpp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e911b88cc584
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Thaodan <theodorstormgrade@gmai.com>
+_pkgname=shpp
+pkgname=$_pkgname-git
+pkgver=33439b2
+pkgrel=1
+pkgdesc="preprocessor written for posix shell"
+url="https://github.com/Thaodan/shpp"
+arch=('any')
+license=('GPL2')
+depends=('sh' 'coreutils' 'sed' 'bc')
+provides=($_pkgname)
+source=("${pkgname}-${pkgver}.tar.gz")
+conflicts=('sh-make-tools')
+source=(git+https://github.com/Thaodan/$_pkgname)
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git rev-parse --short HEAD
+}
+
+build() {
+ cd $srcdir/$_pkgname
+ make PREFIX=/usr
+}
+check() {
+ cd $srcdir/$_pkgname/src
+ make tests
+}
+
+package() {
+ cd $srcdir/$_pkgname
+ make PREFIX=$pkgdir/usr install
+}
+md5sums=('SKIP')