summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2019-02-15 21:14:35 +0100
committerJoan Figueras2019-02-15 21:14:35 +0100
commit1c47c869d08f54a9dacad007b284542dd7f382cb (patch)
tree48db838253c6bf41e3e7ae1f8d2ee1b31efe0e76
parent88b23da4efa126131b406c64e2d34744f5d862ff (diff)
downloadaur-1c47c869d08f54a9dacad007b284542dd7f382cb.tar.gz
Removed iked. THis package will only be QT GUI. Added dependency on ike
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
-rw-r--r--fix-openssl.patch83
-rw-r--r--fix_dirent_access_after_closedir.patch19
-rw-r--r--gui_only.patch19
-rw-r--r--iked.conf9
-rw-r--r--iked.service10
7 files changed, 36 insertions, 166 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df4a7f9918a7..17ff3a02cca2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = shrew-vpn-client
- pkgdesc = A portable VPN client for Linux with Qt GUI
+ pkgdesc = A portable VPN client for Linux - Qt GUI only
pkgver = 2.2.1
- pkgrel = 4
+ pkgrel = 5
url = http://www.shrew.net/
arch = i686
arch = x86_64
@@ -12,23 +12,14 @@ pkgbase = shrew-vpn-client
makedepends = bison
makedepends = cmake
depends = qt4
- depends = openssl-1.0
- optdepends = openldap
- optdepends = logrotate
+ depends = ike
conflicts = shrew-vpn-client-alpha
- backup = etc/iked.conf
source = http://www.shrew.net/download/ike/ike-2.2.1-release.tbz2
source = ikea.desktop
- source = iked.conf
- source = iked.service
- source = fix-openssl.patch
- source = fix_dirent_access_after_closedir.patch
+ source = gui_only.patch
md5sums = 8fc14ac86771ee693d3950757c84f335
md5sums = 5b35a4246eb1b7bd4bfb6780c23d39f2
- md5sums = 3cfe649578267235d60ab7cfb6fb4c57
- md5sums = e90d5922d37f9e45515c5754a3a29c73
- md5sums = c1f793c174db5d7f5c11c8009a967a4d
- md5sums = cb4720dab4f9cae5aeac1e62abc6348b
+ md5sums = eed8f22eedb29cad06abcfe8e513b028
pkgname = shrew-vpn-client
diff --git a/PKGBUILD b/PKGBUILD
index cd60bafcc545..2fca2fc84f9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,37 +3,20 @@
pkgname=shrew-vpn-client
pkgver=2.2.1
-pkgrel=4
-pkgdesc="A portable VPN client for Linux with Qt GUI"
+pkgrel=5
+pkgdesc="A portable VPN client for Linux - Qt GUI only"
arch=('i686' 'x86_64')
url="http://www.shrew.net/"
license=('osi')
-depends=('qt4' 'openssl-1.0')
+depends=('qt4' 'ike')
makedepends=('gcc' 'flex' 'libedit' 'bison' 'cmake')
-optdepends=('openldap' 'logrotate')
conflicts=('shrew-vpn-client-alpha')
-backup=('etc/iked.conf')
source=("http://www.shrew.net/download/ike/ike-$pkgver-release.tbz2"
'ikea.desktop'
- 'iked.conf'
- 'iked.service'
- fix-openssl.patch
- fix_dirent_access_after_closedir.patch)
+ gui_only.patch)
md5sums=('8fc14ac86771ee693d3950757c84f335'
'5b35a4246eb1b7bd4bfb6780c23d39f2'
- '3cfe649578267235d60ab7cfb6fb4c57'
- 'e90d5922d37f9e45515c5754a3a29c73'
- 'c1f793c174db5d7f5c11c8009a967a4d'
- 'cb4720dab4f9cae5aeac1e62abc6348b')
-
-prepare() {
-
- cd $srcdir/ike
- patch -Np1 -i ../fix-openssl.patch
- # https://build.opensuse.org/package/view_file/security/ike/fix_dirent_access_after_closedir.patch
- patch -Np1 -i ../fix_dirent_access_after_closedir.patch
-
-}
+ 'eed8f22eedb29cad06abcfe8e513b028')
build() {
cd $srcdir/ike
@@ -41,6 +24,13 @@ build() {
# Build the whole package
cmake -DQTGUI=YES -DNATT=YES -DLDAP=YES -DSBINDIR=/usr/bin \
-DCMAKE_INSTALL_PREFIX=/usr -DMANDIR=/usr/share/man -DETCDIR=/etc
+
+ # Remove binary and library from make
+ patch -Np1 -i ../gui_only.patch
+# for Component in iked ikec libike libip libidb libith liblog libpfk ; do
+# sed -e "/\/$Component\//d" -i cmake_install.cmake
+# done
+
make
}
@@ -48,15 +38,6 @@ package() {
cd "$srcdir/ike"
make DESTDIR="$pkgdir/" install
- # Install the daemon script
- install -D -m644 $startdir/iked.service $pkgdir/usr/lib/systemd/system/iked.service
-
- # The configuration file is already ready for use; just rename it
- mv $pkgdir/etc/iked.conf.sample $pkgdir/etc/iked.conf
-
- # Prevent logs from growing if logrotate is installed
- install -D -m644 $startdir/iked.conf $pkgdir/etc/logrotate.d/iked.conf
-
# Copy our desktop files
install -D -m644 $srcdir/ike/source/qikea/png/ikea.png $pkgdir/usr/share/icons/ikea.png
install -D -m755 $startdir/ikea.desktop $pkgdir/usr/share/applications/ikea.desktop
diff --git a/fix-openssl.patch b/fix-openssl.patch
deleted file mode 100644
index b0dc30d3c25d..000000000000
--- a/fix-openssl.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -25,6 +25,7 @@ add_definitions( -DUNIX )
-
- include( CheckCSourceCompiles )
- include( CheckLibraryExists )
-+include_directories(BEFORE SYSTEM "/usr/include/openssl-1.0")
-
- set(
- RELVER "2.2.1" )
-@@ -270,7 +271,7 @@ endif( NOT PATH_INC_CRYPTO )
-
- find_library(
- PATH_LIB_CRYPTO
-- NAMES "crypto"
-+ NAMES "libcrypto.so.1.0.0"
- PATHS ${SEARCH_LIB} )
-
- if( NOT PATH_LIB_CRYPTO )
-diff --git a/source/ikec/CMakeLists.txt b/source/ikec/CMakeLists.txt
---- a/source/ikec/CMakeLists.txt
-+++ b/source/ikec/CMakeLists.txt
-@@ -32,7 +32,7 @@ target_link_libraries(
- ss_idb
- ss_ith
- ss_log
-- crypto
-+ ${PATH_LIB_CRYPTO}
- pthread
- edit )
-
-diff --git a/source/iked/CMakeLists.txt b/source/iked/CMakeLists.txt
---- a/source/iked/CMakeLists.txt
-+++ b/source/iked/CMakeLists.txt
-@@ -73,7 +73,7 @@ target_link_libraries(
- ss_ip
- ss_log
- ss_pfk
-- crypto
-+ ${PATH_LIB_CRYPTO}
- pthread )
-
- if( FUNC_LIB_CRYPT )
-diff --git a/source/libike/CMakeLists.txt b/source/libike/CMakeLists.txt
---- a/source/libike/CMakeLists.txt
-+++ b/source/libike/CMakeLists.txt
-@@ -29,7 +29,7 @@ target_link_libraries(
- ss_ike
- ss_idb
- ss_ith
-- crypto )
-+ ${PATH_LIB_CRYPTO} )
-
- set_target_properties(
- ss_ike PROPERTIES
-diff --git a/source/qikea/CMakeLists.txt b/source/qikea/CMakeLists.txt
---- a/source/qikea/CMakeLists.txt
-+++ b/source/qikea/CMakeLists.txt
-@@ -55,7 +55,7 @@ target_link_libraries(
- ss_idb
- ss_ith
- ss_log
-- crypto
-+ ${PATH_LIB_CRYPTO}
- pthread
- ${QT_LIBRARIES} )
-
-diff --git a/source/qikec/CMakeLists.txt b/source/qikec/CMakeLists.txt
---- a/source/qikec/CMakeLists.txt
-+++ b/source/qikec/CMakeLists.txt
-@@ -53,7 +53,7 @@ target_link_libraries(
- ss_idb
- ss_ith
- ss_log
-- crypto
-+ ${PATH_LIB_CRYPTO}
- pthread
- ${QT_LIBRARIES} )
-
---
-2.12.2
-
diff --git a/fix_dirent_access_after_closedir.patch b/fix_dirent_access_after_closedir.patch
deleted file mode 100644
index e3324f127a66..000000000000
--- a/fix_dirent_access_after_closedir.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- a/source/libike/manager.file.cpp 2019-01-02 00:49:44.450296883 +0100
-+++ b/source/libike/manager.file.cpp 2019-01-02 00:52:28.367472254 +0100
-@@ -107,12 +107,14 @@
- found++;
- }
-
-- closedir( dirp );
-- if( dp == NULL )
-+ if( dp == NULL ) {
-+ closedir( dirp );
- return false;
-+ }
-
- config.set_id( dp->d_name );
- index++;
-+ closedir( dirp );
-
- return file_vpn_load( config );
-
diff --git a/gui_only.patch b/gui_only.patch
new file mode 100644
index 000000000000..7293611c8d2f
--- /dev/null
+++ b/gui_only.patch
@@ -0,0 +1,19 @@
+--- a/CMakeLists.txt 2019-02-15 00:25:07.209537217 +0100
++++ b/CMakeLists.txt 2019-02-15 00:27:29.216998985 +0100
+@@ -30,14 +30,8 @@
+ RELVER "2.2.1" )
+
+ subdirs(
+- source/iked
+- source/ikec
+- source/libike
+- source/libip
+- source/libidb
+- source/libith
+- source/liblog
+- source/libpfk )
++ source/qikea
++ source/qikec )
+
+ set(
+ SEARCH_INC
diff --git a/iked.conf b/iked.conf
deleted file mode 100644
index a2efe9135c59..000000000000
--- a/iked.conf
+++ /dev/null
@@ -1,9 +0,0 @@
-/var/log/iked.log {
- notifempty
- missingok
- copytruncate
- rotate 1
- compress
- weekly
-}
-
diff --git a/iked.service b/iked.service
deleted file mode 100644
index a5ce605c45d1..000000000000
--- a/iked.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=iked daemon
-After=syslog.target network.target
-
-[Service]
-Type=forking
-ExecStart=/usr/sbin/iked
-
-[Install]
-WantedBy=multi-user.target