summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorParker Coates2020-08-05 10:35:35 -0300
committerParker Coates2020-08-05 10:40:03 -0300
commit73c189c71766640c4475efafda7f66ca2ce6e074 (patch)
treebcc62ed7aac5abbc2cd6b15dbad2ae12031cdedc
parent1c47c869d08f54a9dacad007b284542dd7f382cb (diff)
downloadaur-73c189c71766640c4475efafda7f66ca2ce6e074.tar.gz
Switch build to Ben Foxmoore's Qt5 fork
• Appended -qt5 to the pkgname • Removed some unused makedepends • Cleaned up CMake patching to run before first cmake run to avoid running cmake twice • Added a .gitignore
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD45
-rw-r--r--gui_only.patch6
4 files changed, 38 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17ff3a02cca2..f76594b69a04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,23 @@
-pkgbase = shrew-vpn-client
- pkgdesc = A portable VPN client for Linux - Qt GUI only
+pkgbase = shrew-vpn-client-qt5
+ pkgdesc = A portable VPN client for Linux - Qt5 port of GUI only
pkgver = 2.2.1
- pkgrel = 5
- url = http://www.shrew.net/
+ pkgrel = 0
+ url = https://github.com/ben-foxmoore/shrew-qt5
arch = i686
arch = x86_64
license = osi
+ makedepends = git
makedepends = gcc
- makedepends = flex
- makedepends = libedit
- makedepends = bison
makedepends = cmake
- depends = qt4
+ depends = qt5-base
depends = ike
- conflicts = shrew-vpn-client-alpha
- source = http://www.shrew.net/download/ike/ike-2.2.1-release.tbz2
+ conflicts = shrew-vpn-client
+ source = shrew-qt5::git://github.com/ben-foxmoore/shrew-qt5.git
source = ikea.desktop
source = gui_only.patch
- md5sums = 8fc14ac86771ee693d3950757c84f335
+ md5sums = SKIP
md5sums = 5b35a4246eb1b7bd4bfb6780c23d39f2
- md5sums = eed8f22eedb29cad06abcfe8e513b028
+ md5sums = 376b119543b4bc00b7875a3c71ab2f18
-pkgname = shrew-vpn-client
+pkgname = shrew-vpn-client-qt5
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7e199a431daa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+shrew-qt5/
+/*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index 2fca2fc84f9e..df32970d61a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,42 @@
-# Maintainer: Christian Hammacher <bmasterc gmail com>
+# Maintainer: Parker Coates <parker.coates gmail com>
# Contributor: Christian Hammacher <bmasterc gmail com>
-pkgname=shrew-vpn-client
+pkgname=shrew-vpn-client-qt5
+_reponame=shrew-qt5
pkgver=2.2.1
-pkgrel=5
-pkgdesc="A portable VPN client for Linux - Qt GUI only"
+pkgrel=0
+pkgdesc="A portable VPN client for Linux - Qt5 port of GUI only"
arch=('i686' 'x86_64')
-url="http://www.shrew.net/"
+url='https://github.com/ben-foxmoore/shrew-qt5'
license=('osi')
-depends=('qt4' 'ike')
-makedepends=('gcc' 'flex' 'libedit' 'bison' 'cmake')
-conflicts=('shrew-vpn-client-alpha')
-source=("http://www.shrew.net/download/ike/ike-$pkgver-release.tbz2"
- 'ikea.desktop'
- gui_only.patch)
-md5sums=('8fc14ac86771ee693d3950757c84f335'
+depends=('qt5-base' 'ike')
+makedepends=('git' 'gcc' 'cmake')
+conflicts=('shrew-vpn-client')
+source=("${_reponame}::git://github.com/ben-foxmoore/${_reponame}.git"
+ 'ikea.desktop'
+ 'gui_only.patch')
+md5sums=('SKIP'
'5b35a4246eb1b7bd4bfb6780c23d39f2'
- 'eed8f22eedb29cad06abcfe8e513b028')
+ '376b119543b4bc00b7875a3c71ab2f18')
build() {
- cd $srcdir/ike
+ cd $srcdir/${_reponame}
- # Build the whole package
- cmake -DQTGUI=YES -DNATT=YES -DLDAP=YES -DSBINDIR=/usr/bin \
- -DCMAKE_INSTALL_PREFIX=/usr -DMANDIR=/usr/share/man -DETCDIR=/etc
-
- # Remove binary and library from make
+ # Remove all non-GUI targets from CMake
patch -Np1 -i ../gui_only.patch
-# for Component in iked ikec libike libip libidb libith liblog libpfk ; do
-# sed -e "/\/$Component\//d" -i cmake_install.cmake
-# done
+
+ cmake -G 'Unix Makefiles' -DQTGUI=YES -DNATT=YES -DLDAP=YES -DSBINDIR=/usr/bin \
+ -DCMAKE_INSTALL_PREFIX=/usr -DMANDIR=/usr/share/man -DETCDIR=/etc
make
}
package() {
- cd "$srcdir/ike"
+ cd "$srcdir/${_reponame}"
make DESTDIR="$pkgdir/" install
# Copy our desktop files
- install -D -m644 $srcdir/ike/source/qikea/png/ikea.png $pkgdir/usr/share/icons/ikea.png
+ install -D -m644 $srcdir/${_reponame}/source/qikea/png/ikea.png $pkgdir/usr/share/icons/ikea.png
install -D -m755 $startdir/ikea.desktop $pkgdir/usr/share/applications/ikea.desktop
}
diff --git a/gui_only.patch b/gui_only.patch
index 7293611c8d2f..d1742e575611 100644
--- a/gui_only.patch
+++ b/gui_only.patch
@@ -1,9 +1,9 @@
--- a/CMakeLists.txt 2019-02-15 00:25:07.209537217 +0100
+++ b/CMakeLists.txt 2019-02-15 00:27:29.216998985 +0100
-@@ -30,14 +30,8 @@
+@@ -33,14 +33,5 @@
RELVER "2.2.1" )
- subdirs(
+-subdirs(
- source/iked
- source/ikec
- source/libike
@@ -12,8 +12,6 @@
- source/libith
- source/liblog
- source/libpfk )
-+ source/qikea
-+ source/qikec )
set(
SEARCH_INC