summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2018-11-07 12:12:05 +0100
committerJoan Figueras2018-11-07 12:12:05 +0100
commit760436c42210c7d9ff5fabe3a894c087965c0d0c (patch)
treeaa049fcdc7cafdc9896f3abd9b845c10b180fd13
parentde22c8bd8c2ec2fb03ac6c80df6d69748fc93027 (diff)
downloadaur-760436c42210c7d9ff5fabe3a894c087965c0d0c.tar.gz
Fix openssl
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--fix-openssl.patch83
3 files changed, 100 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbbab4fdc84e..831faff1d9f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = shrew-vpn-client
pkgdesc = A portable VPN client for Linux with Qt GUI
pkgver = 2.2.1
- pkgrel = 2
+ pkgrel = 3
url = http://www.shrew.net/
arch = i686
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = shrew-vpn-client
makedepends = bison
makedepends = cmake
depends = qt4
- depends = openssl
+ depends = openssl-1.0
optdepends = openldap
optdepends = logrotate
conflicts = shrew-vpn-client-alpha
@@ -21,10 +21,12 @@ pkgbase = shrew-vpn-client
source = ikea.desktop
source = iked.conf
source = iked.service
+ source = fix-openssl.patch
md5sums = 8fc14ac86771ee693d3950757c84f335
md5sums = 5b35a4246eb1b7bd4bfb6780c23d39f2
md5sums = 3cfe649578267235d60ab7cfb6fb4c57
md5sums = e90d5922d37f9e45515c5754a3a29c73
+ md5sums = c1f793c174db5d7f5c11c8009a967a4d
pkgname = shrew-vpn-client
diff --git a/PKGBUILD b/PKGBUILD
index 6be1a11595ec..10418d427aaf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=shrew-vpn-client
pkgver=2.2.1
-pkgrel=2
+pkgrel=3
pkgdesc="A portable VPN client for Linux with Qt GUI"
arch=('i686' 'x86_64')
url="http://www.shrew.net/"
license=('osi')
-depends=('qt4' 'openssl')
+depends=('qt4' 'openssl-1.0')
makedepends=('gcc' 'flex' 'libedit' 'bison' 'cmake')
optdepends=('openldap' 'logrotate')
conflicts=('shrew-vpn-client-alpha')
@@ -16,11 +16,20 @@ backup=('etc/iked.conf')
source=("http://www.shrew.net/download/ike/ike-$pkgver-release.tbz2"
'ikea.desktop'
'iked.conf'
- 'iked.service')
+ 'iked.service'
+ fix-openssl.patch)
md5sums=('8fc14ac86771ee693d3950757c84f335'
'5b35a4246eb1b7bd4bfb6780c23d39f2'
'3cfe649578267235d60ab7cfb6fb4c57'
- 'e90d5922d37f9e45515c5754a3a29c73')
+ 'e90d5922d37f9e45515c5754a3a29c73'
+ 'c1f793c174db5d7f5c11c8009a967a4d')
+
+prepare() {
+
+ cd $srcdir/ike
+ patch -Np1 -i ../fix-openssl.patch
+
+}
build() {
cd $srcdir/ike
diff --git a/fix-openssl.patch b/fix-openssl.patch
new file mode 100644
index 000000000000..b0dc30d3c25d
--- /dev/null
+++ b/fix-openssl.patch
@@ -0,0 +1,83 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,6 +25,7 @@ add_definitions( -DUNIX )
+
+ include( CheckCSourceCompiles )
+ include( CheckLibraryExists )
++include_directories(BEFORE SYSTEM "/usr/include/openssl-1.0")
+
+ set(
+ RELVER "2.2.1" )
+@@ -270,7 +271,7 @@ endif( NOT PATH_INC_CRYPTO )
+
+ find_library(
+ PATH_LIB_CRYPTO
+- NAMES "crypto"
++ NAMES "libcrypto.so.1.0.0"
+ PATHS ${SEARCH_LIB} )
+
+ if( NOT PATH_LIB_CRYPTO )
+diff --git a/source/ikec/CMakeLists.txt b/source/ikec/CMakeLists.txt
+--- a/source/ikec/CMakeLists.txt
++++ b/source/ikec/CMakeLists.txt
+@@ -32,7 +32,7 @@ target_link_libraries(
+ ss_idb
+ ss_ith
+ ss_log
+- crypto
++ ${PATH_LIB_CRYPTO}
+ pthread
+ edit )
+
+diff --git a/source/iked/CMakeLists.txt b/source/iked/CMakeLists.txt
+--- a/source/iked/CMakeLists.txt
++++ b/source/iked/CMakeLists.txt
+@@ -73,7 +73,7 @@ target_link_libraries(
+ ss_ip
+ ss_log
+ ss_pfk
+- crypto
++ ${PATH_LIB_CRYPTO}
+ pthread )
+
+ if( FUNC_LIB_CRYPT )
+diff --git a/source/libike/CMakeLists.txt b/source/libike/CMakeLists.txt
+--- a/source/libike/CMakeLists.txt
++++ b/source/libike/CMakeLists.txt
+@@ -29,7 +29,7 @@ target_link_libraries(
+ ss_ike
+ ss_idb
+ ss_ith
+- crypto )
++ ${PATH_LIB_CRYPTO} )
+
+ set_target_properties(
+ ss_ike PROPERTIES
+diff --git a/source/qikea/CMakeLists.txt b/source/qikea/CMakeLists.txt
+--- a/source/qikea/CMakeLists.txt
++++ b/source/qikea/CMakeLists.txt
+@@ -55,7 +55,7 @@ target_link_libraries(
+ ss_idb
+ ss_ith
+ ss_log
+- crypto
++ ${PATH_LIB_CRYPTO}
+ pthread
+ ${QT_LIBRARIES} )
+
+diff --git a/source/qikec/CMakeLists.txt b/source/qikec/CMakeLists.txt
+--- a/source/qikec/CMakeLists.txt
++++ b/source/qikec/CMakeLists.txt
+@@ -53,7 +53,7 @@ target_link_libraries(
+ ss_idb
+ ss_ith
+ ss_log
+- crypto
++ ${PATH_LIB_CRYPTO}
+ pthread
+ ${QT_LIBRARIES} )
+
+--
+2.12.2
+