summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia Pellegrino2024-06-17 16:25:32 +0200
committerClaudia Pellegrino2024-06-17 16:53:04 +0200
commite38978dfa076eea9baf306a8c0e8b82d0ac3659b (patch)
treea57ad8ecf99f159a18cccd9e8dd3a8c0022f2a56
parentec6cb06e4227320ea53cdd1bc0062ab234dd1572 (diff)
downloadaur-e38978dfa076eea9baf306a8c0e8b82d0ac3659b.tar.gz
Rename static stub that used to be a template
In 18f5113, the template became static. Remove the `.template` suffix and get rid of the template processing step.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
-rw-r--r--shrinko8 (renamed from shrinko8.py.template)0
3 files changed, 5 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5995a19b03ac..06fa6073f0b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -18,7 +18,7 @@ pkgbase = shrinko8
source = shrinko8-1.1.2.tar.gz::https://github.com/thisismypassport/shrinko8/archive/v1.1.2.tar.gz
source = __init__.py.template
source = pyproject.toml.template
- source = shrinko8.py.template
+ source = shrinko8
source = test_cart.p8
sha512sums = 79dfea0a1322a81073cfbd51785f78eafcb62b070154eb8b4878a1482b80257317ae47e39f6b51c4a14f046588bd59307278dfdc1a93983e671e598e0594baa5
sha512sums = e484cb3881923665ff3bf7cb7522f897227896b81d8c8b094f7be8c49d79f1ed6d069bb82d878be36210df80ddf75cb009eb92ea03a2bc9cd3988f651e0bee57
diff --git a/PKGBUILD b/PKGBUILD
index e3b393b564fb..4c796409df28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ source=(
"${pkgname}-${pkgver}.tar.gz::https://github.com/thisismypassport/shrinko8/archive/v${pkgver}.tar.gz"
'__init__.py.template'
'pyproject.toml.template'
- 'shrinko8.py.template'
+ 'shrinko8'
'test_cart.p8'
)
@@ -63,11 +63,6 @@ build() {
echo >&2 'Building the wheel'
python -m build --wheel --no-isolation
-
- echo >&2 'Building the executable'
- mkdir -pv bin
- j2 -f env -o bin/shrinko8 '../shrinko8.py.template' - <<< \
- "site_packages=$(_site_packages)"
}
check() {
@@ -80,7 +75,7 @@ check() {
export PYTHONPATH
echo >&2 'Running minification test'
- python "${srcdir}/${pkgname}-${pkgver}/bin/shrinko8" \
+ python "${srcdir}/shrinko8" \
-m "${srcdir}/test_cart.p8" test_cart_minified.p8
if [[ "$(wc -c < 'test_cart_minified.p8')" -gt 116 ]]; then
printf >&2 '%s\n' 'Unexpected minification output:' '==='
@@ -90,7 +85,7 @@ check() {
fi
echo >&2 'Running PNG generation test'
- python "${srcdir}/${pkgname}-${pkgver}/bin/shrinko8" \
+ python "${srcdir}/shrinko8" \
-m "${srcdir}/test_cart.p8" test_cart.p8.png
}
@@ -100,7 +95,7 @@ package() {
python -I -m installer --destdir="${pkgdir}" dist/*.whl
echo >&2 'Packaging the executable'
- install -D -m 755 -t "${pkgdir}/usr/bin" "bin/${pkgname}"
+ install -D -m 755 -t "${pkgdir}/usr/bin" "../${pkgname}"
echo >&2 'Packaging the README'
install -D -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" \
diff --git a/shrinko8.py.template b/shrinko8
index 0158e22bd030..0158e22bd030 100644
--- a/shrinko8.py.template
+++ b/shrinko8