summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Landau2015-06-27 17:55:05 +0300
committerDaniel Landau2015-06-27 17:55:05 +0300
commitb57b3570979853afe06b488d25a132faa49857cd (patch)
tree0eb4b324c3218910bc8801ac4511bb74205d2308
downloadaur-b57b3570979853afe06b488d25a132faa49857cd.tar.gz
Initial migration from old AUR
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2f98f15b12c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = shrinkpdf
+ pkgdesc = Tiny shell script to shrink an image pdf
+ pkgver = 1.0
+ pkgrel = 2
+ url = http://www.alfredklomp.com/programming/shrinkpdf/
+ arch = any
+ license = BSD
+ depends = ghostscript
+ source = http://www.alfredklomp.com/programming/shrinkpdf/shrinkpdf.sh
+ sha256sums = 24da8a094964a502fb5999ddedad99fba46e52339900d49be9a8d389a43c339e
+
+pkgname = shrinkpdf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03984eaf481b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Daniel Landau <daniel.landau@iki.fi>
+pkgname=shrinkpdf
+pkgver=1.0
+pkgrel=2
+pkgdesc="Tiny shell script to shrink an image pdf"
+arch=('any')
+url="http://www.alfredklomp.com/programming/shrinkpdf/"
+license=('BSD')
+depends=('ghostscript')
+source=(
+http://www.alfredklomp.com/programming/shrinkpdf/shrinkpdf.sh
+)
+sha256sums=('24da8a094964a502fb5999ddedad99fba46e52339900d49be9a8d389a43c339e')
+
+package() {
+ cd "$srcdir/"
+
+ sed -ne '/Copyright/,/POSSIBILITY OF SUCH DAMAGE/p' shrinkpdf.sh > LICENSE
+ install -D LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ install -D shrinkpdf.sh "$pkgdir/usr/bin/shrinkpdf.sh"
+}
+