summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2018-07-25 08:18:44 -0700
committerAlexander F Rødseth2018-07-25 08:18:44 -0700
commit4602dc367d653d87443b50dadebb99b68ba4ecec (patch)
tree71389ddd06c1168d89f04cd95ea75ea0826141a8
downloadaur-4602dc367d653d87443b50dadebb99b68ba4ecec.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5fec29cfb670
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Jul 25 15:18:33 UTC 2018
+pkgbase = shrinky
+ pkgdesc = Build small executables with C++17 (based on dnload)
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/xyproto/shrinky/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ source = git+https://github.com/xyproto/shrinky#tag=v1.0
+ md5sums = SKIP
+
+pkgname = shrinky
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d67f6d7f8bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=shrinky
+pkgver=1.0
+pkgrel=1
+pkgdesc='Build small executables with C++17 (based on dnload)'
+arch=('any')
+url='https://github.com/xyproto/shrinky/'
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools' 'git')
+source=("git+https://github.com/xyproto/shrinky#tag=v$pkgver")
+md5sums=('SKIP')
+
+package() {
+ cd "$pkgname"
+ python setup.py install --optimize=1 --root "$pkgdir"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 shrinky.sh "$pkgdir/usr/bin/$pkgname"
+}
+
+# vim: ts=2 sw=2 et:
+