summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Whatson2019-11-08 11:03:49 +1000
committerAndrew Whatson2019-11-08 11:12:20 +1000
commit05ada12f819f9099d2db8cfaa19d4569022f43fd (patch)
tree0ed69697e9620e6d0e8fb606566cd3acefbf8e9d
downloadaur-05ada12f819f9099d2db8cfaa19d4569022f43fd.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d019e1c2447
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = shroud-git
+ pkgdesc = A simple command-line secret manager using GNU Guile
+ pkgver = v0.1.2.r2.gce77970
+ pkgrel = 1
+ url = https://dthompson.us/projects/shroud.html
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = guile
+ depends = gnupg
+ depends = xclip
+ provides = shroud
+ conflicts = shroud
+ source = git+https://git.dthompson.us/shroud.git
+ sha256sums = SKIP
+
+pkgname = shroud-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8d27ba8fcf6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+/shroud
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1b021be490c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Andrew Whatson <whatson@gmail.com>
+_pkgname=shroud
+pkgname=${_pkgname}-git
+pkgver=v0.1.2.r2.gce77970
+pkgrel=1
+pkgdesc='A simple command-line secret manager using GNU Guile'
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('guile' 'gnupg' 'xclip')
+provides=($_pkgname)
+conflicts=($_pkgname)
+makedepends=('git')
+url="https://dthompson.us/projects/shroud.html"
+source=("git+https://git.dthompson.us/shroud.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd shroud
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd ${_pkgname}
+ ./bootstrap
+}
+
+build() {
+ cd ${_pkgname}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${_pkgname}
+ make DESTDIR="${pkgdir}" install
+}