summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormadflow2017-07-24 20:50:05 +0200
committermadflow2017-07-24 20:50:05 +0200
commit2cd9c199334a18eacadeb696fc846c023787e4d3 (patch)
tree31abe93dcc1089490fcd7e21d4e296940cc7e7ee
parent764cd3641cef733c5d6f6aa6f3ac5f2002971252 (diff)
downloadaur-2cd9c199334a18eacadeb696fc846c023787e4d3.tar.gz
fix build issues
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53af0c6e657b..cdab03bb86aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = shrr
- pkgdesc = Lets you share a file or folder via HTTP
- pkgver = 0.1
+ pkgdesc = Share files via HTTP
+ pkgver = 0.1.1
pkgrel = 1
url = https://gitlab.com/madflow/shrr
arch = any
license = MIT
- makedepends = python-setuptools
+ makedepends = python-setuptools,
+ makedepends = python-pip
depends = python>=3.3,
depends = python-flask
+ source = https://gitlab.com/madflow/shrr/uploads/8fbbb075695c61427816039d46173821/shrr-0.1.1-py3-none-any.whl
pkgname = shrr
diff --git a/PKGBUILD b/PKGBUILD
index c24c7da1877d..ee5d0c37ce39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
-# Maintainer: madflow <madflow@localhost>
+# Do not edit PKGBUILD directly. Edit PKGBUILD.tpl and update the setup.json file
+
+# Maintainer: madflow <madflow@web.de>
pkgname=shrr
-pkgver=0.1
+pkgver=0.1.1
pkgrel=1
-pkgdesc="Lets you share a file or folder via HTTP"
+pkgdesc="Share files via HTTP"
arch=('any')
url="https://gitlab.com/madflow/shrr"
license=(MIT)
groups=()
depends=('python>=3.3', 'python-flask')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools', 'python-pip')
optdepends=()
provides=()
conflicts=()
@@ -17,19 +19,11 @@ backup=()
options=()
install=
changelog=
-source=()
+source=(https://gitlab.com/madflow/shrr/uploads/8fbbb075695c61427816039d46173821/shrr-0.1.1-py3-none-any.whl)
noextract=()
md5sums=() #autofill using updpkgsums
-build() {
- cd "$pkgname-$pkgver"
-
- ./configure --prefix=/usr
- make
-}
-
package() {
- cd "$pkgname-$pkgver"
-
- make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$pkgname-$pkgver"
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps *.whl
} \ No newline at end of file