summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormadflow2017-07-24 09:15:31 +0200
committermadflow2017-07-24 09:15:31 +0200
commit764cd3641cef733c5d6f6aa6f3ac5f2002971252 (patch)
tree64baa04e7f16cff8dfb7b5f42f67e90b196c5e50
downloadaur-764cd3641cef733c5d6f6aa6f3ac5f2002971252.tar.gz
Initial
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD35
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..53af0c6e657b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = shrr
+ pkgdesc = Lets you share a file or folder via HTTP
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://gitlab.com/madflow/shrr
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python>=3.3,
+ depends = python-flask
+
+pkgname = shrr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c24c7da1877d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: madflow <madflow@localhost>
+pkgname=shrr
+pkgver=0.1
+pkgrel=1
+pkgdesc="Lets you share a file or folder via HTTP"
+arch=('any')
+url="https://gitlab.com/madflow/shrr"
+license=(MIT)
+groups=()
+depends=('python>=3.3', 'python-flask')
+makedepends=('python-setuptools')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=()
+noextract=()
+md5sums=() #autofill using updpkgsums
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+} \ No newline at end of file