summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-10-28 16:52:12 -0700
committerAndy Weidenbaum2015-10-28 16:52:12 -0700
commit6cb36d561f074bd9a7a0f927752eca4512ad0d59 (patch)
tree1c9b45cffc8fd2c5042556d00ba72d8ed37cf72a
downloadaur-6cb36d561f074bd9a7a0f927752eca4512ad0d59.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD38
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c08b98e6b9ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = shtk
+ pkgdesc = Collection of reusable modules written in sh that provide common functionality to simplify the implementation of complex shell scripts
+ pkgver = 1.6
+ pkgrel = 1
+ url = https://github.com/jmmv/shtk
+ arch = any
+ license = BSD
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = make
+ source = shtk-1.6.tar.gz::https://github.com/jmmv/shtk/releases/download/shtk-1.6/shtk-1.6.tar.gz
+ sha256sums = 2a3892ce6c624ae5d7a1d96b014fcff0ee6920a3f76ac0ab0b7d4ff16c7a7d0f
+
+pkgname = shtk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aaec2f9c8025
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=shtk
+pkgver=1.6
+pkgrel=1
+pkgdesc="Collection of reusable modules written in sh that provide common functionality to simplify the implementation of complex shell scripts"
+arch=('any')
+makedepends=('autoconf' 'automake' 'make')
+url="https://github.com/jmmv/shtk"
+license=('BSD')
+source=($pkgname-$pkgver.tar.gz::https://github.com/jmmv/$pkgname/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz)
+sha256sums=('2a3892ce6c624ae5d7a1d96b014fcff0ee6920a3f76ac0ab0b7d4ff16c7a7d0f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Building...'
+ #autoreconf -i -s
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib/shtk \
+ --sysconfdir=/etc \
+ --sharedstatedir=/usr/share/shtk \
+ --localstatedir=/var/lib/shtk
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg2 'Installing license...'
+ install -Dm 644 COPYING "$pkgdir/usr/share/licenses/shtk/COPYING"
+
+ msg2 'Installing...'
+ make DESTDIR="$pkgdir" install
+ mv "$pkgdir/usr/tests" "$pkgdir/usr/share/shtk"
+}