summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoelof Rietbroek2018-01-04 17:22:54 +0100
committerRoelof Rietbroek2018-01-04 17:22:54 +0100
commit2386d274e3ae29da0b944ba4f8f86a6894f15602 (patch)
treee93227c67c5c013b520857589f686f3832381ad6
parent80e2f5b1641c2c1189496c9e4366fe72af23a6d8 (diff)
downloadaur-2386d274e3ae29da0b944ba4f8f86a6894f15602.tar.gz
update to version 4.1
-rw-r--r--.SRCINFO8
-rw-r--r--ChangeF90stops.patch60
-rw-r--r--PKGBUILD28
3 files changed, 17 insertions, 79 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 257c1c595fbd..4f49eb7e17c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = shtools-fortran
pkgdesc = Tools for working with spherical harmonics
- pkgver = 4.0
+ pkgver = 4.1
pkgrel = 1
url = https://shtools.oca.eu
arch = any
@@ -9,10 +9,8 @@ pkgbase = shtools-fortran
depends = fftw
depends = blas
depends = lapack
- source = ChangeF90stops.patch
- source = https://github.com/SHTOOLS/SHTOOLS/archive/v4.0.tar.gz
- md5sums = 98fce6f29ee3e89acaabdfc08fa391f3
- md5sums = c314c0da11292953bf2bb120601b208a
+ source = https://github.com/SHTOOLS/SHTOOLS/archive/v4.1.tar.gz
+ md5sums = 3923b9980a5d5b0795996af44a97ea3b
pkgname = shtools-fortran
diff --git a/ChangeF90stops.patch b/ChangeF90stops.patch
deleted file mode 100644
index fd6a6e035c3a..000000000000
--- a/ChangeF90stops.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-diff -ura SHTOOLS-4.0/examples/fortran/SHLocalizedAdmitCorr/LocalizedAdmitCorr.f95 SHTOOLS-4.0-new/examples/fortran/SHLocalizedAdmitCorr/LocalizedAdmitCorr.f95
---- SHTOOLS-4.0/examples/fortran/SHLocalizedAdmitCorr/LocalizedAdmitCorr.f95 2016-12-16 11:45:23.000000000 +0100
-+++ SHTOOLS-4.0-new/examples/fortran/SHLocalizedAdmitCorr/LocalizedAdmitCorr.f95 2017-09-01 23:30:53.571947470 +0200
-@@ -43,7 +43,7 @@
- allocate(pot(2,degmax+1,degmax+1), stat = astat(2))
- if (astat(1) /= 0 .or. astat(2) /= 0) then
- print*, "Problem allocating arrays TOPO and POT", astat(1), astat(2)
-- stop
-+ stop
- endif
-
- print*, "Reading = ", topography_file
-@@ -110,7 +110,7 @@
- read(*,*) lwin
- print*, "Corresponding approximate Shannon number = ", (lwin+1)*theta0/pi
- else
-- stop
-+ stop
- endif
-
- allocate(tapers(lwin+1, (lwin+1)**2), stat = astat(1))
-@@ -119,7 +119,7 @@
-
- if (astat(1) /= 0 .or. astat(2) /= 0 .or. astat(3) /= 0 ) then
- print*, "Problem allocatig arrays for tapers, taper_order, or eigenvalues", astat(1), astat(2), astat(3)
-- stop
-+ stop
- endif
-
- call SHReturnTapers(theta0, lwin, tapers, eigenvalues, taper_order)
-@@ -159,7 +159,7 @@
- if (astat(1) /= 0 .or. astat(2) /= 0 .or. astat(3) /= 0 .or. astat(4) /= 0 &
- .or. astat(5) /=0) then
- print*, "Problem allocating memory"
-- stop
-+ stop
- endif
-
- !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
-diff -ura SHTOOLS-4.0/src/SHLocalizedAdmitCorr.f95 SHTOOLS-4.0-new/src/SHLocalizedAdmitCorr.f95
---- SHTOOLS-4.0/src/SHLocalizedAdmitCorr.f95 2016-12-16 11:45:23.000000000 +0100
-+++ SHTOOLS-4.0-new/src/SHLocalizedAdmitCorr.f95 2017-09-01 23:25:54.828607734 +0200
-@@ -131,7 +131,7 @@
- exitstatus = 2
- return
- else
-- stop
-+ stop
- end if
-
- end if
-@@ -147,7 +147,7 @@
- exitstatus = 1
- return
- else
-- stop
-+ stop
- end if
-
- else if (size(corr) < lmax-lwin+1) then
diff --git a/PKGBUILD b/PKGBUILD
index 1589b7f64030..e7ad7df18abc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,8 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
+# Arch User repository PKGBUILD file
+# Builds the fortran part of the shtools library
# Maintainer: Roelof Rietbroek <roelof@wobbly.earth>
pkgname=shtools-fortran
-pkgver=4.0
+pkgver=4.1
pkgrel=1
pkgdesc="Tools for working with spherical harmonics"
arch=('any')
@@ -14,30 +11,33 @@ license=('BSD 3-clause')
groups=()
depends=("fftw" "blas" "lapack")
makedepends=("gcc-fortran")
-source=("ChangeF90stops.patch" "https://github.com/SHTOOLS/SHTOOLS/archive/v$pkgver.tar.gz")
+source=("https://github.com/SHTOOLS/SHTOOLS/archive/v$pkgver.tar.gz")
noextract=()
-md5sums=('98fce6f29ee3e89acaabdfc08fa391f3'
- 'c314c0da11292953bf2bb120601b208a')
+md5sums=('3923b9980a5d5b0795996af44a97ea3b')
validpgpkeys=()
prepare() {
- cd ${srcdir}/SHTOOLS-${pkgver}/
- patch -p1 -i "$srcdir/ChangeF90stops.patch"
+ _startdir=${PWD}
+ # cd ${srcdir}/SHTOOLS-${pkgver}/
}
build() {
cd ${srcdir}/SHTOOLS-${pkgver}/
make fortran
make fortran-mp
+ cd ${_startdir}
}
check() {
cd ${srcdir}/SHTOOLS-${pkgver}/
- make fortran-tests
- make fortran-tests-mp
+ make run-fortran-tests-no-timing
+ cd ${_startdir}
+
}
package() {
cd ${srcdir}/SHTOOLS-${pkgver}/
- make DESTDIR="$pkgdir/" PREFIX=usr/ install-fortran
+ make DESTDIR="$pkgdir/" PREFIX=usr/ install-fortran
+ cd ${_startdir}
}
+