summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorariasuni2018-01-25 22:26:04 +0100
committerariasuni2018-01-25 22:26:04 +0100
commit15bc30d0bcf9f5e342da58645793b9b564bba6b6 (patch)
tree27e73b528d7bbdc084da1154962b3018605e99c1
parent38fd62c7fdc744e29477f32983993ffbf8fcad7f (diff)
downloadaur-15bc30d0bcf9f5e342da58645793b9b564bba6b6.tar.gz
update to 2.7.0 and add LICENCE file
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fe4aee870a6..3d9a38c3b7f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = shub-bin
pkgdesc = Scrapinghub Command Line Client
- pkgver = 2.5.1
+ pkgver = 2.7.0
pkgrel = 1
- url = https://scrapinghub.com/
+ url = https://github.com/scrapinghub/shub/
arch = x86_64
license = BSD
- optdepends = python-scrapy: scrapy python script.
- provides = shub=2.5.1
+ provides = shub=2.7.0
conflicts = shub
- source = https://github.com/scrapinghub/shub/releases/download/v2.5.1/shub-v2.5.1-linux-x64.tar.gz
- sha256sums = 5e449fa2378f6f32b047aac2efd981d462440b70e762fa3eceff0a28347a3842
+ source = https://github.com/scrapinghub/shub/releases/download/v2.7.0/shub-v2.7.0-linux-x64.tar.gz
+ source = https://raw.githubusercontent.com/scrapinghub/shub/master/LICENSE
+ sha256sums = 5d41a49f9ff083c33669ee44c69d6898b4bc9ead6946fccd88a285cad048fe56
+ sha256sums = 49ea6190a7f081686a8c71faba2f915c9dbdbee99572e7b26612f30098a130a1
pkgname = shub-bin
diff --git a/PKGBUILD b/PKGBUILD
index 4a9a144e5bd1..e1312595949c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,23 @@
-# Maintainer: Crotok <crotok [at] mailbox [dot] org>
+# Contributor: Crotok <crotok [at] mailbox [dot] org>
+# Maintainer: Mélanie Chauvel (ariasuni) <perso@hack-libre.org>
_pkgbase=shub
pkgname=shub-bin
-pkgver=2.5.1
+pkgver=2.7.0
pkgrel=1
pkgdesc="Scrapinghub Command Line Client"
arch=("x86_64")
conflicts=("${_pkgbase}")
-url="https://scrapinghub.com/"
+url="https://github.com/scrapinghub/shub/"
license=("BSD")
provides=("shub=${pkgver}")
-optdepends=('python-scrapy: scrapy python script.')
-source=("https://github.com/scrapinghub/shub/releases/download/v2.5.1/shub-v${pkgver}-linux-x64.tar.gz")
-sha256sums=("5e449fa2378f6f32b047aac2efd981d462440b70e762fa3eceff0a28347a3842")
+source=("https://github.com/scrapinghub/shub/releases/download/v${pkgver}/shub-v${pkgver}-linux-x64.tar.gz"
+ "https://raw.githubusercontent.com/scrapinghub/shub/master/LICENSE")
+sha256sums=('5d41a49f9ff083c33669ee44c69d6898b4bc9ead6946fccd88a285cad048fe56'
+ '49ea6190a7f081686a8c71faba2f915c9dbdbee99572e7b26612f30098a130a1')
package() {
- # Binary file
install -Dm755 "${srcdir}/shub" "${pkgdir}/usr/bin/shub"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}